Ticket #2832 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

mcedit: unable to save changes in "Safe save" mode

Reported by: onlyjob Owned by: slavazanko
Priority: major Milestone: 4.8.5
Component: mcedit Version: 4.8.3
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

If mcedit is configured to use "Safe save" I'm unable to save changes to existing file.

Same problem is for editor_option_save_mode=2 (backup mode)

Saving to new file works.

This appears to be a regression from 4.8.1

Change History

comment:1 Changed 6 years ago by Graham

I can confirm the same issue, but with the latest Stable build (4.8.1.3). I compiled this on Debian Squeeze using the following build options: ./configure --enable-vfs-undelfs --without-samba --with-x --with-screen=slang

The only option that works is "Quick save", both "Safe save" and "Do backups with following extensions" fail to save. This doesn't happen with version 4.8.1.1, which works fine.

comment:2 Changed 6 years ago by Graham

In addition to above, may I point to this post in Debian Bugs that refers to this problem: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673252#24

"strace shows that mc tries to create a temporary file with the initial /
missing from the filename. When trying to safe save /var/tmp/new-file:"

comment:3 Changed 6 years ago by slavazanko

  • Status changed from new to accepted
  • Owner set to slavazanko
  • Milestone changed from Future Releases to 4.8.5

comment:4 follow-up: ↓ 5 Changed 6 years ago by slavazanko

  • Keywords stable-candidate added
  • Branch state changed from no branch to on review

Created branch 2832_mcedit_safe_save.
Review please.

comment:5 in reply to: ↑ 4 Changed 6 years ago by onlyjob

Replying to slavazanko:

Review please.


I tried the change and it seems to be working well.

Thanks for fixing this - I believe this was quite an important bug.

Well done.

Cheers,
Dmitry.

comment:6 Changed 6 years ago by andrew_b

  • Votes for changeset set to andrew_b

comment:7 Changed 6 years ago by angel_il

  • Votes for changeset changed from andrew_b to andrew_b angel_il
  • Branch state changed from on review to approved

comment:8 Changed 6 years ago by slavazanko

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b angel_il to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

merged to master:

git log --pretty=oneline 9cec254..e2fb1c8

comment:9 Changed 6 years ago by slavazanko

  • Status changed from testing to closed
  • Keywords stable-candidate removed

merged to stable:

git log --pretty=oneline d80f631..d60e43a
Note: See TracTickets for help on using tickets.