Ticket #2826 (closed defect: duplicate)

Opened 10 years ago

Last modified 9 years ago

pasting into mcedit eats newlines (kinda reopening the #1736)

Reported by: rsv Owned by:
Priority: critical Milestone:
Component: mcedit Version: master
Keywords: x integration Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

--
ubuntu 12.04 using XFCE and KDE - both have same behaviour

--
mc -V :

GNU Midnight Commander 4.8.1
Built with GLib 2.31.20
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;
--

https://www.midnight-commander.org/ticket/1736 - see this one.

I am having the same problems even now - 3 years after #1736 was fixed...

My workaround is to re-compile mc with --without-x

How I reproduce it - select multiline text from anywhere and try to paste with ctrl-shift-v into mcedit - (does not matter from guake/konsole ).

I dont know how to debug this . So please tell me where in the source tree to see these things:

  • the input string that is in the clipboard before pasting
  • the string that goes into mc

Somewhere in the middle the newlines are converted to spaces.
And it is because my linux user has some X11 related setting - cause with a vanilla test linux user all is fine and no bug occurs.

Any hotughts will be helpful. Thanks.

Change History

comment:1 Changed 10 years ago by dl9pf

Confirmed to happen also on openSUSE 12.2 .

comment:2 Changed 9 years ago by linvinus

  • Priority changed from minor to critical

I can confirm.
same problem in ubuntu 12.10 libvte 2.90 mc 4.8.3

this trick is working for me http://www.midnight-commander.org/ticket/1710#comment:1
if i press shift then form terminal popup menu select paste, new lines are correct.
or shift + middle mouse

comment:3 Changed 9 years ago by pfalcon

This probably should be treated as duplicate of #2661 which has working patches.

comment:4 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone 4.8 deleted

Closed as duplicate of #2661.

Note: See TracTickets for help on using tickets.