Ticket #2823 (reopened defect)

Opened 6 years ago

Last modified 3 years ago

wrong handling of new VFS naming scheme

Reported by: phil Owned by:
Priority: major Milestone: Future Releases
Component: mc-vfs Version: 4.8.3
Keywords: ftp Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

GNU Midnight Commander 4.8.3
Built with GLib 2.28.6
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

Steps to reproduce:

  1. You're in /usr/local.
  2. cd ftp://myserver.net (use your favorite ftp server here)
  3. Tab to other panel.
  4. echo %D gives /usr/local/ftp://myserver.net. If you try to copy a file to FTP, the F5 dialog suggests the same wrong target path.

Change History

comment:1 Changed 6 years ago by slavazanko

  • Status changed from new to closed
  • Resolution set to invalid

Try to use latest master.
4.8.3 have bug in FTP-module, this bug have fixed in another ticket. So I sure that copy/move operations on 'master' version will be completed sucesfully.

Also, path /usr/local/ftp://myserver.net didn't contain errors. This right path, I try to explain: look, you stayed on /usr/local directory, next you want go to any network connection (or even just enter to archive). On panel header you'll see the last path element, but mc always knows full path with local FS. This needed for case, when you'll leave VFS-connection by pressing '..' dir entry. In this case you'll returned to /usr/local dir. For example, you may do:

cd /var/tmp/ftp://kernel.org
echo %D

and you'll see /var/tmp/ftp://kernel.org as well. next, press to '..' dir entry. you'll placed in /var/tmp directory. This behaviour completely unrelated to your issue, and troubles with copying/moving to the ftp resource is gone from the latest 'master' branch.

comment:2 Changed 6 years ago by slavazanko

  • Status changed from closed to reopened
  • Resolution invalid deleted

oh, sorry, you don't have troubles with copying, you have troubles with displaying destination FTP-path.
My mistake, I confirmed this issue and heve reoped ticket.

comment:3 Changed 6 years ago by phil

So if /usr/local/ftp://myserver.net is correct value for %D, how can I get ftp://myserver.net in command line?

I tried to build master, but had some automake-related problem:

Making all in po
make[2]: Entering directory `/home/phil/build/mc/po'
make[2]: *** No rule to make target `all'.  Stop.

comment:4 follow-up: ↓ 5 Changed 6 years ago by andrew_b

Run autogen.sh at first.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 6 years ago by phil

Replying to andrew_b:

Run autogen.sh at first.

Ah, ok. autogen.sh did not work for me at first, so I did aclocal && automake && autoconf && ./configure manually, but it was not enough. Luckily, autogen.sh (after installing autopoint or what?) is working well now. Maybe doc/HACKING needs some update.

So I see, now both ftp://myserver.net and /somelocaldir/ftp://myserver.net are working well in F5 dialog. Just the second format looks scary to a user who had not read this ticket before ;). So now I don't care about what is displayed in the dialog, but I want to have a normal, non-MC coded path in the command line after %D substitution.

comment:6 in reply to: ↑ 5 Changed 6 years ago by phil

Replying to phil:

So I see, now both ftp://myserver.net and /somelocaldir/ftp://myserver.net are working well in F5 dialog. Just the second format looks scary to a user who had not read this ticket before ;).

And if an error occurs while copying, the error message replaces the middle part of the destination path by ... (or ~ ?) to fit in dialog, so you don't see the magic ftp:// part at all, and it looks like it is copying to a local path. Confusing.

comment:7 Changed 3 years ago by andrew_b

  • Milestone set to Future Releases
Note: See TracTickets for help on using tickets.