Ticket #2818 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

shift - fn keys not working

Reported by: tempUser Owned by:
Priority: major Milestone:
Component: mc-tty Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Since the past few weeks the shift - fn keys aren't working. For example shift-f6 to rename files. I tried downgrading, as well as using the latest git version of xkeyboard-config (which was earlier known to cause a similar problem with mc), but no difference.

$ LC_MESSAGES=C mc -V

GNU Midnight Commander 4.8.3
Built with GLib 2.32.1
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

$ mc --configure-options

'--prefix=/usr' '--sysconfdir=/etc' '--mandir=/usr/share/man' '--enable-background' '--enable-charset' '--enable-largefile' '--with-edit' '--with-gpm-mouse' '--with-mmap' '--enable-vfs-smb' '--with-screen=slang' '--with-subshell' '--with-vfs' '--with-x' '--without-debug' '--without-gnome' '--without-included-gettext' '--libexecdir=/usr/lib' 'CFLAGS=-march=i686 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2' 'LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu'

Change History

comment:1 Changed 6 years ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-tty
  • Version master deleted
  • Resolution set to invalid
  • Milestone Future Releases deleted

It's impossible. Developing mc, I build mc many times per day. Everything works fine for me as in 4.8.3 as in recent master.
Key handling didn't modify for a long, long time. Please try remember what software you had updated before this problem raised.

comment:2 Changed 6 years ago by tempUser

Yes, i found that this problem only occurs within tmux. And i had changed $TERM to screen-256color for tmux a few weeks back, and that's the cause of this problem.

Note: See TracTickets for help on using tickets.