Ticket #2769 (closed defect: fixed)

Opened 10 years ago

Last modified 8 years ago

Crash on compare files with one panel in quick view mode

Reported by: onlyjob Owned by: andrew_b
Priority: major Milestone: 4.8.3
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description

Bug-Debian: http://bugs.debian.org/666692

MC crashes (Segmentation fault) on "Compare files" if one of the panels in "Quick view" mode.

4.8.1, 4.8.2 and current 'master' versions are affected.

Cheers,
Dmitry.

Change History

comment:1 Changed 10 years ago by andrew_b

  • Milestone changed from 4.8.3 to Future Releases

I'm unable reproduce this.

  1. Select any files on panels.
  2. Switch other panel to "Quick view mode" (C-x q).
  3. Compare file (C-x C-d)
  4. No crash.

comment:2 follow-up: ↓ 3 Changed 10 years ago by onlyjob

Could it be because you invoke 'compare directories' (C-x d) instead of 'compare files'?

Could you please try to invoke 'compare files' from menu? (Command-->[Compare files])

This is very persistent on amd64.

GNU Midnight Commander 4.8.2-32-g18df85a
Built with GLib 2.30.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

'--build=x86_64-linux-gnu' '--prefix=/usr' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' '--libdir=${prefix}/lib/x86_64-linux-gnu' '--libexecdir=${prefix}/lib/x86_64-linux-gnu' '--disable-maintainer-mode' '--disable-dependency-tracking' 'AWK=awk' '--libexecdir=${prefix}/lib' '--with-x' '--with-screen=slang' '--disable-rpath' '--disable-static' '--enable-vfs-undelfs' '--enable-tests' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fPIE -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security' 'LDFLAGS=-fPIE -pie -Wl,-z,relro -Wl,-z,now' 'CPPFLAGS=-D_FORTIFY_SOURCE=2'

comment:3 in reply to: ↑ 2 Changed 10 years ago by andrew_b

Replying to onlyjob:

Could it be because you invoke 'compare directories' (C-x d) instead of 'compare files'?

No.

Could you please try to invoke 'compare files' from menu? (Command-->[Compare files])

I tried that.

This is very persistent on amd64.

Ah, I'm on i686. But it should not be dependent on arch.

comment:4 Changed 10 years ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Milestone changed from Future Releases to 4.8.3

comment:5 Changed 10 years ago by andrew_b

  • Keywords stable-candidate added
  • Branch state changed from no branch to on review

Branch: 2769_compare_files_crash (parent: master).
changeset:a5835115824804ab8efbc6c953ca20b35742e766

Version 0, edited 10 years ago by andrew_b (next)

comment:6 Changed 10 years ago by onlyjob

Andrew, you're awesome - I've just tried your changeset and the problem has gone, no more crash.

Fantastic, thanks very much for rapid and professional response!

All the best,
Dmitry.

comment:7 Changed 10 years ago by andrew_b

I've moved check to the upper level.

comment:8 Changed 10 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:9 Changed 10 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • Branch state changed from on review to approved

comment:10 Changed 10 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko angel_il to committed-master
  • Resolution set to fixed

Merged to master: [d25ac6a9119a789ddf5c0d234af8a60f98aac7e8]

git log --pretty=oneline c494f7b..d25ac6a

comment:11 Changed 10 years ago by andrew_b

  • Status changed from testing to closed
  • Keywords stable-candidate removed
  • Votes for changeset changed from committed-master to committed-master committed-stable

Cherry-picked to 4.8.1-stable: [108cdbfaca45af5f320873db459e0459ee72965b]

comment:12 Changed 8 years ago by andrew_b

  • Branch state changed from approved to merged
Note: See TracTickets for help on using tickets.