Ticket #2752 (closed defect: worksforme)

Opened 8 years ago

Last modified 8 years ago

'mc_global_t' has no member named 'we_are_background'

Reported by: pavlinux Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

# git pull
# configure
# LC_ALL=C make

background.c: In function 'do_background':
background.c:543:18: error: 'mc_global_t' has no member named 'we_are_background'
make: [background.o] Error 1

Change History

comment:2 Changed 8 years ago by pavlinux

У меня конфигуря с --enable-background

comment:3 follow-up: ↓ 6 Changed 8 years ago by slavazanko

As first, language of this bugtracker is English. Good English or bad English - isn't important; should be English.

Second, I constantly build mc with --enable-background configure option (include latest master) and no any build error was raised to me. This bug looks like 'worksForMe'.

Can tou check '#define ENABLE_BACKGROUND ' in your config.h file?
What compiler you use?

Last edited 8 years ago by slavazanko (previous) (diff)

comment:4 Changed 8 years ago by slavazanko

  • Status changed from new to closed
  • Resolution set to worksforme

comment:5 Changed 8 years ago by andrew_b

  • Milestone Future Releases deleted

comment:6 in reply to: ↑ 3 Changed 8 years ago by pavlinux

Replying to slavazanko:

As first, language of this bugtracker is English. Good English or bad English - isn't important; should be English.

Second, I constantly build mc with --enable-background configure option (include latest master) and no any build error was raised to me. This bug looks like 'worksForMe'.

Can tou check '#define ENABLE_BACKGROUND ' in your config.h file?
What compiler you use?

$ grep BACK ./config.h
#define WITH_BACKGROUND 1

gcc version 4.6.1 20110926 [gcc-4_6-branch revision 179180] (SUSE Linux)

comment:7 Changed 8 years ago by pavlinux

BASH:

./autogen.sh

./configure --prefix=/usr \
            --sysconfdir=/usr/share \
            --sharedstatedir=/usr/share \
            --libexecdir=/usr/share \
            --localstatedir=/var \
            --libdir=/usr/lib64 \
            --includedir=/usr/include \
            --datarootdir=/usr/share \
            --datadir=/usr/share \
            --infodir=/usr/share/info \
            --localedir=/usr/share/locale \
            --mandir=/usr/share/man \
            --build="x86_64-gnu-linux" \
            --host="x86_64-gnu-linux" \
            --disable-doxygen-doc \
            --disable-extcharset \
            --enable-netcode \
            --enable-background \
            --enable-utf8 \
            --with-mmap \
            --with-x \
            --with-vfs \
            --with-mcfs \
            --with-samba \
            --enable-vfs-smb \
            --with-configdir=/etc/samba \
            --with-codepagedir=/usr/lib64/samba/codepages \
            --without-gpm-mouse \
            --with-subshell \
            --with-screen=slang \
            --with-slang-libs=/usr/lib64 \
            --with-edit \
            --without-ext2undel \
            --without-libintl-prefix \
            --without-libiconv-prefix;

Last edited 8 years ago by pavlinux (previous) (diff)

comment:8 Changed 8 years ago by pavlinux

Yet more :)

make[3]: Entering directory `/media/disk/src/MC/mc/src/filemanager'

CC libmcfilemanager_la-boxes.lo

boxes.c: In function 'jobs_fill_listbox':
boxes.c:459:5: error: unknown type name 'TaskList?'
boxes.c:459:20: error: 'task_list' undeclared (first use in this function)
boxes.c:459:20: note: each undeclared identifier is reported only once for each function it appears in
boxes.c:471:38: error: request for member 'state' in something not a structure or union
boxes.c:471:55: error: request for member 'info' in something not a structure or union
boxes.c:474:16: error: request for member 'next' in something not a structure or union
boxes.c: In function 'task_cb':
boxes.c:483:5: error: unknown type name 'TaskList?'
boxes.c:498:11: error: request for member 'state' in something not a structure or union
boxes.c:498:21: error: 'Task_Stopped' undeclared (first use in this function)
boxes.c:503:11: error: request for member 'state' in something not a structure or union
boxes.c:503:21: error: 'Task_Running' undeclared (first use in this function)
boxes.c:513:9: warning: implicit declaration of function 'unregister_task_running' [-Wimplicit-function-declaration]
boxes.c:513:9: warning: nested extern declaration of 'unregister_task_running' [-Wnested-externs]
boxes.c:513:36: error: request for member 'pid' in something not a structure or union
boxes.c:513:45: error: request for member 'fd' in something not a structure or union
boxes.c:515:13: error: request for member 'pid' in something not a structure or union
make[3]: * [libmcfilemanager_la-boxes.lo] Error 1
make[3]: Leaving directory `/media/disk/src/MC/mc/src/filemanager'
make[2]:
* [all-recursive] Error 1
make[2]: Leaving directory `/media/disk/src/MC/mc/src'
make[1]: * [all-recursive] Error 1
make[1]: Leaving directory `/media/disk/src/MC/mc'
make:
* [all] Error 2

comment:9 follow-up: ↓ 10 Changed 8 years ago by angel_il

i can't reproduce this

comment:10 in reply to: ↑ 9 Changed 8 years ago by pavlinux

Replying to angel_il:

i can't reproduce this

Я не знаю, чё за фигня, спасает полное удаление каталога git репы,
и скачивание, после каждого git pull вылазят глюки...
ни autogen.sh, ни distclean не спасают.

If you need english, use GoogleTranslate? =)

Note: See TracTickets for help on using tickets.