Ticket #2748 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Wrong message in menu item "Delete tagged files if a copy exists in the other directory"

Reported by: victor-homyakov Owned by: andrew_b
Priority: trivial Milestone: 4.8.2
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description

What version of Midnight Commander is used?
LC_MESSAGES=C mc -V
GNU Midnight Commander 4.7.5.5
Built with GLib 2.24.1
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

What steps will reproduce the problem?

  1. Select on the left pane files, which not exist on the right pane
  2. Place cursor on ".." entry
  3. Press F2 and select menu item "Delete tagged files if a copy exists in the other directory"

What is the expected output?
something like

file1 has no copy in /right/pane/path/file1: NOT deleted
file2 has no copy in /right/pane/path/file2: NOT deleted

for each file (file1, file2 etc.)

What do you see instead?

.. has no copy in /right/pane/path/..: NOT deleted
.. has no copy in /right/pane/path/..: NOT deleted

for each file

This happens because of wrong message in menu script (%f points to current file, not to file which was tested):

D   Delete tagged files if a copy exists in the other directory
...
        echo "%f has no copy in %D/%f: NOT deleted"

should be something like

D   Delete tagged files if a copy exists in the other directory
...
        echo "$i has no copy in %D: NOT deleted"

Change History

comment:1 Changed 8 years ago by victor-homyakov

  • Priority changed from major to trivial

comment:2 Changed 8 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Blocked By 2740, 2741 added

Thanks! Patch is applied in cleanup branches.

comment:3 Changed 8 years ago by andrew_b

  • Milestone changed from Future Releases to 4.8.2

comment:4 Changed 8 years ago by slavazanko

  • Blocked By 2741 removed

(In #2741) > upload source packages and checksums to http://www.midnight-commander.org/downloads
done

update Wiki start page with latest release number

done

write an announcement: list user visible changes (bugs and features)

done

comment:5 Changed 8 years ago by slavazanko

  • Blocked By 2740 removed

comment:6 Changed 8 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset set to committed-master committed-stable
  • Resolution set to fixed
  • Branch state changed from no branch to merged

comment:7 Changed 8 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.