Ticket #2695 (closed task: fixed)

Opened 8 years ago

Last modified 7 years ago

VFS reorganization: the vfs_path_t expansion to 'src/' subdirectory

Reported by: slavazanko Owned by: slavazanko
Priority: major Milestone: 4.8.2
Component: mc-vfs Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description

For unification of the work with patches, we need to expand the vfs_path_t usage to sources related to UI (not only to lib/ subdir).

Change History

comment:1 Changed 8 years ago by slavazanko

  • Status changed from new to accepted
  • Owner set to slavazanko

comment:2 Changed 8 years ago by slavazanko

  • Branch state changed from no branch to on review

Created branch 2695_expansion_to_src
Initial changeset:7f0d3b42f8bd782a3a0667edb7259c66fc69ef8b

Review, please.

comment:3 Changed 8 years ago by andrew_b

  • Branch state changed from on review to on rework

comment:4 Changed 8 years ago by andrew_b

  • Blocking 2451 added

comment:5 Changed 8 years ago by slavazanko

  • Branch state changed from on rework to on review

comment:6 Changed 8 years ago by slavazanko

  • Keywords stable-candidate added

comment:7 Changed 8 years ago by andrew_b

  • Blocking 2451 removed

comment:8 Changed 8 years ago by andrew_b

  • Votes for changeset set to andrew_b

comment:9 Changed 8 years ago by angel_il

  • Keywords stable-candidate removed
  • Votes for changeset changed from andrew_b to andrew_b angel_il
  • Branch state changed from on review to approved

comment:10 Changed 8 years ago by slavazanko

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b angel_il to committed-master
  • Milestone changed from Future Releases to 4.8.2
  • Keywords stable-candidate added
  • Resolution set to fixed
  • Blocking 62, 2454 removed

Merged to master:

git log --pretty=oneline 963ee34...4047403

comment:11 Changed 8 years ago by slavazanko

  • Status changed from testing to reopened
  • Resolution fixed deleted
  • Blocking 2608 added

Have bug with branch:

  • run mc
  • press Shift-F4 (create new file in editor)
  • type any char

segfault here

comment:12 Changed 8 years ago by slavazanko

  • Status changed from reopened to accepted

comment:13 Changed 8 years ago by slavazanko

  • Votes for changeset committed-master deleted
  • Branch state changed from approved to on review

Created branch 2695_editor_segfault

Review, please.

comment:14 Changed 8 years ago by angel_il

  • Votes for changeset set to angel_il

comment:15 Changed 8 years ago by andrew_b

  • Votes for changeset changed from angel_il to angel_il andrew_b
  • Branch state changed from on review to approved

comment:16 Changed 8 years ago by andrew_b

  • Votes for changeset changed from angel_il andrew_b to committed-master
  • Blocking 2608 removed
  • Branch state changed from approved to merged

comment:17 follow-up: ↓ 18 Changed 8 years ago by slyfox

  • Branch state changed from merged to on rework

This change likely led to newly appeared regression.
mc enters busy loop when someone deletes current directory:

$ cd /tmp
$ mkdir x
$ cd x
$ mc
$ rmdir ../x
<black screen. mc 100% busy loops>

comment:18 in reply to: ↑ 17 Changed 8 years ago by andrew_b

Fixed in 2740_cleanup.

comment:19 Changed 8 years ago by slavazanko

  • mkdir ro_dir
  • chmod 555 ro_dir
  • Shift+F4
  • type any symbols
  • press ESC, try to save

Segfault here.

comment:20 Changed 8 years ago by slavazanko

  • Votes for changeset committed-master deleted
  • Branch state changed from on rework to on review

Created branch 2695_editor_segfault
Initial changeset:5b787f35899d6e9120992a860614d7db4e614518

Review, please.

comment:21 Changed 8 years ago by angel_il

  • Votes for changeset set to angel_il

comment:22 Changed 8 years ago by andrew_b

  • Votes for changeset changed from angel_il to angel_il andrew_b
  • Branch state changed from on review to approved

comment:23 Changed 8 years ago by slavazanko

  • Status changed from accepted to testing
  • Votes for changeset changed from angel_il andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

merged to master:

git log --pretty=oneline 61ee9ce...0f9083f

comment:24 Changed 8 years ago by andrew_b

Since this ticket is stable - candidate, following commits must be cherry-picked to 4.8.1-stable after porting this ticket to 4.8.1-stable:
[62bbe532056a0b2d0c075a8232f2c0721c863cac]
[8b8c9a4f348439bc11bdaa3ce9f3c9f1032d6825]
[c2406adfce138444ad842f75b65d64c2668a24fc]

Last edited 7 years ago by slavazanko (previous) (diff)

comment:25 Changed 7 years ago by slavazanko

  • Blocking 2753 added

(In #2753) Merged to master:

git log --pretty=oneline 5b84f73..408ba2a

comment:26 Changed 7 years ago by slavazanko

  • Blocking 2758 added

(In #2758) merged to master:

git log --pretty=oneline 7ae8530..88483f5

comment:27 Changed 7 years ago by slavazanko

  • Blocking 2759 added

(In #2759) merged to master:

git log --pretty=oneline 9d72cf5..d52b1dc

comment:28 Changed 7 years ago by andrew_b

  • Blocking 2762 added

comment:29 Changed 7 years ago by slavazanko

  • Keywords stable-candidate removed
  • Status changed from testing to closed
  • Votes for changeset changed from committed-master to committed-master committed-stable

Cherry-picked to stable:

git log --pretty=oneline 50a146ce...1e92692

comment:30 Changed 7 years ago by slavazanko

  • Blocking 2753 removed

(In #2753) Picked to stable as part of #2695

comment:31 Changed 7 years ago by slavazanko

  • Blocking 2758 removed

(In #2758) Picked to stable as part of #2695

comment:32 Changed 7 years ago by slavazanko

  • Blocking 2759 removed

(In #2759) Picked to stable as part of #2695

comment:33 Changed 7 years ago by slavazanko

  • Blocking 2762 removed

(In #2762) Picked to stable as part of #2695

comment:34 Changed 7 years ago by slavazanko

  • Blocked By 2765 added

(In #2765) Created branch 2765_vfs_directory_sizes

Review, please.

comment:35 Changed 7 years ago by slavazanko

  • Blocked By 2765 removed

(In #2765) Also merged to stable.

comment:36 Changed 7 years ago by slavazanko

  • Blocked By 2777 added

(In #2777) created branch 2777_vfs_stale_symlinks

Review, please.

comment:37 Changed 7 years ago by slavazanko

  • Blocked By 2777 removed

(In #2777) Also merged to stable

Note: See TracTickets for help on using tickets.