Ticket #2667 (closed defect: duplicate)

Opened 8 years ago

Last modified 8 years ago

Fish subshell doesnt work

Reported by: elpresidento Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

mc -V
GNU Midnight Commander 4.7.5.3
Sestaveno s GLib 2.28.8
Používá se knihovna ncurses
S vestavěným editorem
Se standardní podporou podshellu
S podporou operací na pozadí
S podporou myši v konzolích Xterm a Linux
S podporou X11 událostí
S podporou internacionalizace
S podporou více kódových stránek
Virtuální souborové systémy: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish
Typy dat: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

Tested on two systems Gentoo Linux and Sabayon Linux.

  1. installed app-shells/fish and app-misc/mc
  2. in env exists var SHELL=/bin/fish
  3. mc after change dir still show Warning: Cannot change to /home/user. or Warning: Cannot change to /. (dot is in the end) and brakes panels. After returning from C-o it shows:

The Commander can't change to the directory that the subshell claims you are in. Perhaps you have deleted your working directory, or given yourself extra access permissions with the "su" command?

After change var SHELL all is OK.

Change History

comment:1 follow-up: ↓ 2 Changed 8 years ago by andrew_b

What is SHELL=/bin/fish ?

comment:2 in reply to: ↑ 1 Changed 8 years ago by elpresidento

Replying to andrew_b:

What is SHELL=/bin/fish ?

env | grep SHELL

Version 0, edited 8 years ago by elpresidento (next)

comment:3 Changed 8 years ago by andrew_b

man mc says:

The subshell support is a compile time option, that works with the shells: bash, tcsh and zsh.

comment:4 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Duplicate of #231.

Note: See TracTickets for help on using tickets.