Ticket #2660 (closed enhancement: fixed)

Opened 7 years ago

Last modified 5 years ago

Selection is not reset and selection mode is not exited after CK_Store

Reported by: vitalif Owned by: angel_il
Priority: major Milestone: 4.8.7
Component: mcedit Version: 4.8.0
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description

There was a change in 4.8.0 - selection block is no more reset and editor remains in the selection mode after pressing CK_Store (Ctrl-Ins). I.e. if you start selecting a block using F3 and then just press Ctrl-Ins without pressing F3 again, you'll remain in selection mode, and if you go somewhere after it, the block changes.

I think it should be either reset as in previous versions, or at least the selection mode should be finished.

Why this was changed in 4.8.0 at all?

Attachments

mc-4.8.0-reset-after-store.diff (358 bytes) - added by vitalif 7 years ago.
Patch to return old behaviour
mc-4.8.10-editor-drop-selection-on-CK_Store-configurable.patch (2.0 KB) - added by sknaumov 5 years ago.
For those who want good old mc-4.7 behavior and don't want to recompile mc.

Change History

Changed 7 years ago by vitalif

Patch to return old behaviour

comment:1 Changed 7 years ago by vitalif

P.S: this happens when "Persistent selection" option is on.

comment:2 Changed 7 years ago by slavazanko

4.7.5 have same behaviour. Also, selection remained with block copy operation too, like:

  • start test selection by pressing F3
  • press F5 for copy selection
  • continue selection (selection isn't interrupted).

Is this broken?

comment:3 Changed 7 years ago by vitalif

4.7.5 maybe, I didn't test it...
I don't really understand how can you copy selection with F5 while remaining in selection mode?
I.e. you can, but only to the position of selection end.
If you move the cursor into another place, the selection will also be changed and you won't copy what you want.

comment:4 Changed 6 years ago by angel_il

branch: 2660_mcedit_reset_selection

parent: master

please review

comment:5 Changed 6 years ago by angel_il

  • Priority changed from minor to major
  • Version changed from 4.8.0 to master
  • Type changed from defect to enhancement
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.7

comment:6 Changed 6 years ago by andrew_b

  • Votes for changeset set to andrew_b
  • Version changed from master to 4.8.0

comment:7 Changed 6 years ago by andrew_b

  • Owner set to angel_il
  • Status changed from new to assigned

comment:8 Changed 6 years ago by angel_il

  • Status changed from assigned to accepted

comment:9 Changed 6 years ago by slavazanko

  • Votes for changeset changed from andrew_b to andrew_b slavazanko
  • Branch state changed from on review to approved

comment:10 Changed 6 years ago by angel_il

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b slavazanko to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:11 Changed 6 years ago by andrew_b

  • Keywords stable-candidate added

comment:12 Changed 6 years ago by andrew_b

  • Status changed from testing to closed
  • Keywords stable-candidate removed
  • Votes for changeset changed from committed-master to committed-master committed-stable

Cherry-picked to 4.8.1-stable: [c123e8cd701a5410720afb4eb88364812645d86b].

Changed 5 years ago by sknaumov

For those who want good old mc-4.7 behavior and don't want to recompile mc.

comment:13 Changed 5 years ago by andrew_b

Ticket #3111 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.