Ticket #2642 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

mc 4.8.0 will NOT build

Reported by: guido Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.0
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

My compiler gcc 4.5.2 "chokes & bails out" on lines 384 & 385 in main.c.

383 (void) setlocale(...);
384 (void) bindtextdomain(...);
385 (void) textdomain(...);

If I remove ALL the type casts (void), as it was in 4.8.0-pre2, everything builds & functions correctly.

Needs fixing, I think.

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by ossi

i win! :-D
dupe of #2639

comment:2 in reply to: ↑ 1 Changed 7 years ago by guido

Replying to ossi:

i win! :-D
dupe of #2639

Yes, you do! Now, we know it's real! Guido

comment:3 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone 4.8.1 deleted
Note: See TracTickets for help on using tickets.