Ticket #2615 (closed defect: duplicate)

Opened 8 years ago

Last modified 3 months ago

Wrong links owner when copying directory structure

Reported by: bradatec Owned by:
Priority: major Milestone:
Component: mc-core Version: master
Keywords: Cc: howaboutsynergy@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

It seems that "Preserve attributes" are not correctly preserved for softlinks in directory strucure while copying it.
Eg copying the tree as a root let the soft links owner set to root while normal files obtain correct (ie original) owner and group set.

Change History

comment:1 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.5.2 deleted
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Duplicate of #2278.

comment:2 Changed 8 years ago by ossi

this duplicate resolution seems bogus.

for file permissions, this is a cantfix-bacause-pointless - chmod(1) and chmod(2) are pretty explicit about that.

for the file ownership, lchown(2) needs to be used on symlinks.

comment:3 Changed 8 years ago by andrew_b

  • Status changed from closed to reopened
  • Version set to master
  • Resolution duplicate deleted
  • Milestone set to 4.8

comment:4 Changed 8 years ago by andrew_b

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Milestone 4.8 deleted

Duplicate of #17.

comment:5 Changed 3 months ago by howaboutsynergy

  • Cc howaboutsynergy@… added
Note: See TracTickets for help on using tickets.