Ticket #2600 (closed defect: wontfix)

Opened 8 years ago

Last modified 2 years ago

mc viewer freezes for minutes when scrolling to the end of large file

Reported by: shadowlmd Owned by:
Priority: major Milestone:
Component: mcview Version: 4.7.0.9
Keywords: Cc: gotar@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Put output of mc -V command here.

GNU Midnight Commander 4.7.0.9
Virtual File System: tarfs, extfs, cpiofs, ftpfs, fish, undelfs
With builtin Editor
Using system-installed S-Lang library with terminfo database
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Data types: char 8 int 32 long 64 void * 64 off_t 64 ecs_char 8

What steps will reproduce the problem?

  1. Press F3 on a large file (~4GiB)
  2. Press END

What is the expected output?

  1. Instantly see end of file, like in any other internal viewers, for example in FAR Manager.

What do you see instead?

  1. I have time to drink a cup of tea or two before I see the end of file or mc will allow any input at all. I cannot even interrupt it. It also eats up to 150MiB of RAM in process.

PS

I'm not sure if it's fixed in later versions, but this is the latest available in official PPA repository (ppa:zaytsev/ppa) for Lucid.

Change History

comment:1 Changed 8 years ago by angel_il

Try 4.7.5.x

comment:2 Changed 8 years ago by shadowlmd

I cannot try it, since official PPA is not updated.

comment:3 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to wontfix

For a long time we have 4.7.5.x stable series. 4.7.0.x branch is not supported in upstream. Ask your maintainer to update mc to last stable release.

comment:4 Changed 8 years ago by gotar

  • Cc gotar@… added

This was fixed in #2229 (however much work needs to be done), so either make your distributor use that version, or backport patches.

comment:5 Changed 2 years ago by andrew_b

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.