Ticket #2591 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

mouse clicks ignored on the bottom line of editor

Reported by: mnk Owned by: andrew_b
Priority: minor Milestone: 4.8.0-pre2
Component: mcedit Version: master
Keywords: Cc: gotar@…
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master committed-stable

Description

I've noticed an odd behavior - probably just a result of "off by 1".
In X (but independent of terminal - same for sakura and xterm), if I open a document for editing, mouse clicks don't move the cursor to the bottom line.
The line with function keys right below it still gets activated by mouse clicks.

Change History

comment:1 Changed 8 years ago by andrew_b

  • Status changed from new to accepted
  • Keywords stable-candidate added
  • Version changed from 4.7.5.2 to master
  • Milestone changed from Future Releases to 4.8.0-pre2
  • Owner set to andrew_b
  • Blocking 2261 added

Well, the problem is deeply and more complicated than it looks. A lot of corrections in editor are required. All of them are useful for #2261.

Branch:2591_editor_bottom_line_click (parent: master).
Initial changeset:a01f77ee76135626880450d1d7c600404eb67fec

comment:2 Changed 8 years ago by andrew_b

  • Branch state changed from no branch to on review

comment:3 Changed 8 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:4 follow-up: ↓ 5 Changed 8 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • Branch state changed from on review to approved

stable-candidate?

Version 0, edited 8 years ago by angel_il (next)

comment:5 in reply to: ↑ 4 Changed 8 years ago by andrew_b

Replying to angel_il:

stable candidate?

Definitely yes.

Last edited 8 years ago by slavazanko (previous) (diff)

comment:6 Changed 8 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko angel_il to committed-master
  • Resolution set to fixed
  • Blocking 2261 removed
  • Branch state changed from approved to merged

Merged to master.
changeset:c4af1f250cbcd860dd99d80511999d6d6da81ca3

git log --pretty=oneline c819eb1..c4af1f2

comment:7 Changed 8 years ago by andrew_b

  • Status changed from testing to closed
  • Keywords stable-candidate removed
  • Votes for changeset changed from committed-master to committed-master committed-stable

Cherry-picked to stable.
Initial changeset:2ca4d6abb59e9fd112d2941910670d000415baac

comment:8 Changed 8 years ago by gotar

  • Cc gotar@… added
Note: See TracTickets for help on using tickets.