Ticket #2577 (closed defect: duplicate)

Opened 8 years ago

Last modified 2 years ago

quick search fails for names with comma sign

Reported by: bircoph Owned by:
Priority: minor Milestone:
Component: mc-search Version: 4.8.0-pre1
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by andrew_b) (diff)

Hello,

Quick search of file (or directory) completion fails if name contains coma sign ",". To reproduce:

1) $ touch ab,cd ab_cd ab.cd ab:cd
2) type C-s and try to type these file names, it will fail only for "ab,cd".

$ mc --version
GNU Midnight Commander 4.8.0-pre1
Built with GLib 2.28.8
Using the ncurses library
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Well, actually this is a git snapshot from 23:33:55 11.07.2011.

Change History

comment:1 Changed 8 years ago by andrew_b

  • Description modified (diff)
  • Summary changed from mini-status search failes for names with coma sign to quick search failes for names with coma sign

comment:2 Changed 7 years ago by phil

  • Summary changed from quick search failes for names with coma sign to quick search fails for names with comma sign

confirmed in 4.8.3

comment:3 Changed 4 years ago by boris

  • Component changed from mc-core to mc-search

A special case of #2309. Comma is not handled properly by mc_search__glob_translate_to_regex().

comment:4 Changed 4 years ago by andrew_b

  • Blocked By 2309 added

comment:5 Changed 4 years ago by slavazanko

  • Blocked By 2309 removed

(In #2309) Merged to master:

git log --pretty=oneline f4faf60..6ca737d

comment:6 Changed 2 years ago by mooffie

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #2309.
This got fixed by #2309.

comment:7 Changed 2 years ago by mooffie

Ticket #3350 has been marked as a duplicate of this ticket.

comment:8 Changed 2 years ago by andrew_b

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.