Ticket #2551 (closed defect: duplicate)

Opened 8 years ago

Last modified 8 years ago

No Warning Given When Changing Write-Protected Files On Remote Systems

Reported by: wimpog Owned by:
Priority: major Milestone: 4.8
Component: mcedit Version: 4.7.5.2
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

When editing a file on a remote system that doesn't have write permissions, MC doesn't give any warning, however, the changes are not saved. It would be very helpful to know that a particular file can't be edited because of permissions, than make a lot of edits and then find out later, they went down the drain.

$ mc -V
GNU Midnight Commander 4.7.5.2
Built with GLib 2.27.93
Using the ncurses library
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Change History

comment:1 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

Actually duplicate of #1688.

Note: See TracTickets for help on using tickets.