Ticket #2547 (new defect)

Opened 8 years ago

Last modified 4 years ago

Shell prompt does not get redrawn

Reported by: RomaHagen Owned by:
Priority: minor Milestone: Future Releases
Component: mc-core Version: 4.7.5.1
Keywords: prompt, redrawn Cc: gotar@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

$ mc -V

GNU Midnight Commander 4.7.5.1
Built with GLib 2.28.0
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

Steps to reproduce:
Press F7 (or anything else to open some dialog)
Press Cancel
Shell prompt is not redrawn.
To get the prompt redrawn go to some directory.

The bug is in the git://midnight-commander.org/git/mc.git also.

I have checked.

Also, see the screenshot in attachment.

Attachments

shell_prompt.png (11.5 KB) - added by RomaHagen 8 years ago.

Change History

Changed 8 years ago by RomaHagen

comment:1 Changed 8 years ago by andrew_b

I never see this bug and I unable reproduce it. What terminal do you use?

comment:2 Changed 8 years ago by RomaHagen

hm.. strange. I tried with all the possible terminals: xterm, konsole, lxterminal, gnome-terminal and in Linux console. And I can always reproduce it. I tried on two machines. My distribution is openSuSE 11.4.

comment:3 Changed 8 years ago by ossi

does ctrl-L (redraw) make it appear?

comment:4 Changed 8 years ago by RomaHagen

no, but it appears after pressing Tab (changing the panel), for example. Or, as I already said, after changing the current directory.

comment:5 Changed 8 years ago by ymarkovitch

I confirm the bug. Same situation: OpenSUSE 11.4, mc 4.7.5.1, any terminal. I have 5 OpenSUSE 11.4 installations, all get this bug. Extremely annoying, I've downgraded to mc 4.6.0.

comment:6 Changed 7 years ago by gotar

  • Cc gotar@… added
  • Branch state set to no branch

comment:7 Changed 7 years ago by phil

  • Summary changed from Shell promt doest get redrawn to Shell prompt does not get redrawn

comment:8 Changed 4 years ago by andrew_b

  • Milestone changed from 4.8 to Future Releases
Note: See TracTickets for help on using tickets.