Ticket #2502 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

Screen corruption with non-printable chars

Reported by: gotar Owned by:
Priority: major Milestone:
Component: mcdiff Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

While diffing files with characters beyond currently printable charset (e.g. UTF-encoded with some 7 or 8-bit codepage set) every one of them is represented by '<MN>' hex code, however line width isn't recalculated. This causes really bad effect - see attached file (extreme case - comparing binary files).
I think I've already mentioned this somewhere, but can't find it now (and sorry, but this site is loading soooo slooooooow, that it's virtually impossible to search for more than 2 phrases and not get bored).

Attachments

mc-diff.png (32.6 KB) - added by gotar 9 years ago.

Change History

Changed 9 years ago by gotar

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.5 deleted
  • Resolution set to duplicate
  • Milestone 4.8 deleted

Duplicate of #2180.

Try use Google to search in this site.

comment:2 Changed 9 years ago by gotar

Thanks, I should have found this by component filter.

Note: See TracTickets for help on using tickets.