Ticket #2453 (reopened defect)

Opened 8 years ago

Last modified 3 years ago

Screen corruption after viewing UTF-8 file

Reported by: victor-homyakov Owned by: andrew_b
Priority: major Milestone: Future Releases
Component: mc-core Version: 4.7.4
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Empty place on file panel is sometimes corrupted with unicode symbols from viewed file. Steps to reproduce:

  1. Make new empty directory on the left panel
  2. Place into that directory attached file
  3. View file (F3)
  4. Close viewer(F3 again)

Some symbols from the file are left on the panel (see attached screenshots).

Attachments

google-chrome.desktop (4.5 KB) - added by victor-homyakov 8 years ago.
This file causes panel corruption after closing viewer
screenshot1.png (120.6 KB) - added by victor-homyakov 8 years ago.
Opened viewer
screenshot2.png (120.3 KB) - added by victor-homyakov 8 years ago.
Corrupted panel
corruption.png (22.8 KB) - added by birdie 8 years ago.

Change History

Changed 8 years ago by victor-homyakov

This file causes panel corruption after closing viewer

comment:1 follow-ups: ↓ 2 ↓ 3 Changed 8 years ago by andrew_b

What is google-chrome.desktop?

comment:2 in reply to: ↑ 1 Changed 8 years ago by andrew_b

Replying to andrew_b:

What is google-chrome.desktop?

Аh. sorry... It is a test file.

Changed 8 years ago by victor-homyakov

Opened viewer

Changed 8 years ago by victor-homyakov

Corrupted panel

Changed 8 years ago by birdie

comment:3 in reply to: ↑ 1 Changed 8 years ago by birdie

Replying to andrew_b:

What is google-chrome.desktop?

Just view any binary file - it corrupts the screen 100% of the time.

Pressing Ctrl + O twice resolves the problem.

However it seems like it's not strictly MC's issue, because I can reproduce it with a plain terminal session (see the attachment corruption.png):

$ cd /usr/bin
$ cat antiword.bin | head
press Ctrl + L

And what's more, pressing Ctrl + L in MC does nothing. So, it's probably not MC's bug at all.

comment:4 Changed 7 years ago by andrew_b

  • Status changed from new to accepted
  • Keywords stable-candidate added
  • severity changed from no branch to on review
  • Owner set to andrew_b
  • Milestone changed from 4.8 to 4.8.0-pre1

As a solution, we can clear screen before redrawing panels.

Created 2453_screen_corruption patch (parent: master).
changeset:580d273430e7f0d2d327c4ba164ea8b493c931df

comment:5 Changed 7 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:6 Changed 7 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • severity changed from on review to approved

comment:7 Changed 7 years ago by slavazanko

  • severity changed from approved to no branch
  • Branch state set to approved

comment:8 Changed 7 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko angel_il to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:9 Changed 7 years ago by andrew_b

  • Status changed from testing to reopened
  • Resolution fixed deleted

Reverted changeset:f809e6cf7a8b6584f1500d049f133557152dab6d.
changeset:17033652eebef7ba1c095f576ec8a1aedc172cfe

While navigating in main menu (from one submenu to another one) or after closing a dialog, the screen is blinking.

comment:10 Changed 7 years ago by andrew_b

  • Keywords stable-candidate removed
  • Votes for changeset committed-master deleted
  • Branch state changed from merged to no branch
  • Milestone changed from 4.8.0-pre1 to 4.8

comment:11 Changed 5 years ago by andrew_b

In 4.8.10 this bug is not reproducible for me.

Does anybody confirm this bug?

comment:12 Changed 3 years ago by andrew_b

  • Milestone changed from 4.8 to Future Releases
Note: See TracTickets for help on using tickets.