Ticket #2448 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

crash in copy progress dialog

Reported by: ossi Owned by: andrew_b
Priority: critical Milestone: 4.7.5
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description

i guess this goes without comment:

Program terminated with signal 8, Arithmetic exception.
#0  0x080e7dca in __udivdi3 ()
#1  0x080a3487 in copy_file_file_display_progress (tctx=0x91e2300, ctx=0x91ee078,
    src_path=0x921ab00 "/home/obuddenh/maildir-troll/qt-preview-feedback/.mbsyncstate.journal",
    dst_path=0x91ef638 "./maildir-troll-backup/qt-preview-feedback/.mbsyncstate.journal") at file.c:532
#2  copy_file_file (tctx=0x91e2300, ctx=0x91ee078,
    src_path=0x921ab00 "/home/obuddenh/maildir-troll/qt-preview-feedback/.mbsyncstate.journal",
    dst_path=0x91ef638 "./maildir-troll-backup/qt-preview-feedback/.mbsyncstate.journal") at file.c:1500
#3  0x080a3d55 in copy_dir_dir (tctx=0x91e2300, ctx=0x91ee078, s=0x91e79d8 "/home/obuddenh/maildir-troll/qt-preview-feedback",
    _d=0x91e9300 "./maildir-troll-backup/qt-preview-feedback", toplevel=0, move_over=0, do_delete=0, parent_dirs=0x92093c8)
    at file.c:1805
#4  0x080a3e0a in copy_dir_dir (tctx=0x91e2300, ctx=0x91ee078, s=0x921b030 "/home/obuddenh/maildir-troll",
    _d=0x91f4068 "./maildir-troll-backup", toplevel=1, move_over=0, do_delete=0, parent_dirs=0x0) at file.c:1797
#5  0x080a567e in panel_operate (source_panel=0x91fb458, operation=OP_COPY, force_single=1) at file.c:2480
#6  0x0809a197 in copy_cmd_local () at cmd.c:839
#7  0x080bb62a in panel_execute_cmd (panel=0x91fb458, command=<value optimized out>) at panel.c:2745
#8  0x08061ec7 in send_message (h=0x91ed378, key=1015, event=0xffaa1660) at ../../lib/widget/widget-common.h:132
#9  dlg_key_event (h=0x91ed378, key=1015, event=0xffaa1660) at dialog.c:476
#10 dlg_process_event (h=0x91ed378, key=1015, event=0xffaa1660) at dialog.c:1113
#11 0x0806247a in frontend_run_dlg (h=0x91ed378) at dialog.c:529
#12 run_dlg (h=0x91ed378) at dialog.c:1145
#13 0x080b379e in create_panels_and_run_mc () at midnight.c:877
#14 do_nc () at midnight.c:1600
#15 0x0805714b in main (argc=3, argv=0xffaa18d4) at main.c:527

Change History

comment:1 Changed 8 years ago by andrew_b

Is verbose off?

comment:2 Changed 8 years ago by ossi

no

comment:3 Changed 8 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • severity changed from no branch to on review
  • Milestone changed from 4.8 to 4.7.5

Hm, I can't reproduce this division by zero.

Created 2448_copy_progress_crash branch.
Initial changeset:fc80aac0450dc703154c9f8029963a9b64110200\

comment:4 follow-up: ↓ 5 Changed 8 years ago by ossi

the reason is probably that the first copied file deep in the tree is empty.

the patch looks hacky, but i don't know the surrounding code. will it show something like "---" when the ETA is unreasonably large?

comment:5 in reply to: ↑ 4 Changed 8 years ago by andrew_b

Replying to ossi:

will it show something like "---" when the ETA is unreasonably large?

I don't know. :)

comment:6 Changed 8 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:7 Changed 8 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • severity changed from on review to approved

comment:8 Changed 8 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko angel_il to committed-master
  • Resolution set to fixed
  • severity changed from approved to merged

Merged to master.
changeset:a557605cac158264c0ad0b8a454e9021cbb885dd

git log --pretty=oneline 31d440c..a557605

comment:9 Changed 8 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.