Ticket #244 (closed enhancement: fixed)

Opened 10 years ago

Last modified 9 years ago

Shared clipboard for the mc editor, form fields, panel and command prompt.

Reported by: angel_il Owned by: angel_il
Priority: major Milestone: 4.7.0-pre4
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description (last modified by angel_il) (diff)

It is necessary to organise the shared clipboard for the mc editor, form fields, panel and command prompt.
Clipboard mechanism should be like editor (Ctrl+W) without dialog 'Save Block'.

Change History

comment:1 Changed 10 years ago by angel_il

  • Status changed from new to accepted
  • Owner set to angel_il
  • Type changed from defect to enhancement

comment:2 follow-up: ↓ 3 Changed 10 years ago by kdave

Quoting from the first patch:

-{ALT ('a'), copy_current_pathname},
+{ALT ('a'), copy_to_clip_cmd},

Please explain why do you redefine Alt-a . Please explain why do you need to add a concept of a clipboard to mc itself. I understand that it may be useful in the mcedit, but why is it needed to take it elsewhere? What's wrong with GPM and mouse to copy&paste text around?

comment:3 in reply to: ↑ 2 Changed 10 years ago by angel_il

Replying to kdave:

Quoting from the first patch:

-{ALT ('a'), copy_current_pathname},
+{ALT ('a'), copy_to_clip_cmd},

Please explain why do you redefine Alt-a . Please explain why do you need to add a

sorry it's bug im test mechanism and commited raw source.
i'm not planing replace ALT ('a'). maybe Ctrl + W or some...

I understand that it may be useful in the mcedit, but why is it needed to take it elsewhere? What's wrong with GPM and mouse to copy&paste text around?

one litle trouble, when filename longer panel width you can't copy this filename.
i'm everytime need have list selected files in clipboard.

comment:4 Changed 10 years ago by angel_il

  • Keywords review added

please view reworked branch

comment:5 Changed 10 years ago by angel_il

  • Description modified (diff)

comment:6 Changed 10 years ago by winnie

  • Keywords review removed
  • severity set to on review

comment:7 Changed 9 years ago by angel_il

  • Version changed from 4.6.2 to master
  • Milestone changed from 4.7 to 4.7.0-pre3

comment:8 Changed 9 years ago by slavazanko

  • Blocked By 212 added

comment:9 Changed 9 years ago by slavazanko

  • severity changed from on review to on hold

comment:10 Changed 9 years ago by angel_il

  • Milestone changed from 4.7.0-pre3 to 4.7.0-pre4

comment:11 Changed 9 years ago by slavazanko

  • Blocked By 212 removed

(In #212) Need to restore editor key bindings.

comment:12 Changed 9 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:13 Changed 9 years ago by slavazanko

  • severity changed from on hold to on review

comment:14 Changed 9 years ago by slavazanko

#1713 duplicate of this ticket.

comment:15 Changed 9 years ago by iNode

Please don't forget write branch name and ref to changeset.

comment:16 Changed 9 years ago by angel_il

branch: 244_share_clipboard

comment:18 Changed 9 years ago by andrew_b

  • Votes for changeset changed from slavazanko to slavazanko andrew_b
  • severity changed from on review to approved

comment:19 Changed 9 years ago by angel_il

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko andrew_b to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:20 Changed 9 years ago by angel_il

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.