Ticket #2414 (reopened enhancement)

Opened 8 years ago

Last modified 7 years ago

CmdLink should provide some defaults

Reported by: gotar Owned by:
Priority: trivial Milestone: Future Releases
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

F9,f,l or ctrl-x,l pops up empty, which is inconsistent with all the other dialogs. It should be prefilled, especially since #2161, with either second panel directory (like CmdCopy) or current filename (like shift-CmdCopy) or both (like it was proposed in #1907 and then reverted). I can't make my mind what is better for this operation since last 1,6 hour, but maybe this should be both with cursor placed between the two parts? This way one could do shift-home/end,del to remove the part he doesn't want and modify remaining.

Change History

comment:1 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.4 deleted
  • Resolution set to duplicate
  • Milestone 4.7 deleted

I'd like to close this ticket as duplicate of #1380.

comment:2 Changed 8 years ago by gotar

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Sorry, but it has nothing to do with history handling discussion or even #204, it's related to copy operation at most.

Prefilling with second panel directory only (like CmdCopy) doesn't make much sense since this dialog behaves differently than copy/move when directory is given - instead creating link with source filename _inside_ specified directory, it throws an error "link: File exists (17)".

As it is not possible to link directory ("link: Operation not permitted (1)"), the dialog shouldn't even fire unless file is selected.

And I wonder if instead fixing these issues it wouldn't be better to incorporate link() into copy dialog (either as [ ] option or as [Link] button besides [OK]).

comment:3 Changed 8 years ago by gotar

  • Version set to master
  • Milestone set to 4.7

comment:4 Changed 7 years ago by andrew_b

  • Branch state set to no branch
  • Milestone changed from 4.7 to Future Releases
Note: See TracTickets for help on using tickets.