Ticket #2391 (reopened defect)

Opened 8 years ago

Last modified 5 years ago

shell connecting by mc 4.7.0.6

Reported by: Schneider Owned by:
Priority: major Milestone: Future Releases
Component: mc-vfs Version: 4.8.8
Keywords: ssh, shell-connection Cc: gotar@…, zaytsev, sorin.sbarnea@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Shell connection throw mc hanged up when I try make it. I can do nothing on screen at the enclosure. After allowed autorisation and several steps connection hange up on step
fish: reading directory.... (in russsian at the screenshot)

I use Ubuntu 10.10. What's wrong with my mc?

Attachments

fish_ reading direstory.... hang up.JPG (148.1 KB) - added by Schneider 8 years ago.
connection hang up
another connection.JPG (124.0 KB) - added by Schneider 8 years ago.
by another connection you can see processlist

Change History

Changed 8 years ago by Schneider

connection hang up

Changed 8 years ago by Schneider

by another connection you can see processlist

comment:1 follow-up: ↓ 2 Changed 8 years ago by angel_il

fish wait password from you

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 8 years ago by Schneider

Replying to angel_il:

fish wait password from you

No, I am logged on. I've typed correct password.

If I was wrong specialy 3 times mc was not hanged up.
If I typed correct password on the screen flash several operation and
hanged up at the step:
fish: reading directory.... (in russsian at the screenshot)

With respect.
MC User

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 8 years ago by gotar

  • Cc gotar@… added

Replying to Schneider:

No, I am logged on. I've typed correct password.

But used some old/broken package from dumb distro and didn't use search?

If I was wrong specialy 3 times mc was not hanged up.
If I typed correct password on the screen flash several operation and
hanged up at the step:

#2347 #2289 - however this is master branch.

First try newest stable (4.7.0.9 currently), then decide who to blame (like ubudubu packagers).

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 8 years ago by Schneider

Replying to gotar:

Replying to Schneider:

No, I am logged on. I've typed correct password.

But used some old/broken package from dumb distro and didn't use search?

If I was wrong specialy 3 times mc was not hanged up.
If I typed correct password on the screen flash several operation and
hanged up at the step:

#2347 #2289 - however this is master branch.

First try newest stable (4.7.0.9 currently), then decide who to blame (like ubudubu packagers).

I used search and I've saw both #2347 #2289 tickets. But my case different.

comment:5 follow-up: ↓ 7 Changed 8 years ago by Schneider

So. Ok I've added PPA by recomendation this site.
mc -V

GNU Midnight Commander, версия 4.7.0.9
Виртуальная файловая система: tarfs, extfs, cpiofs, ftpfs, fish, undelfs
Со встроенным редактором
С установленной в системе библиотекой S-Lang с базой данных terminfo
C поддержкой внутренней командной оболочки
С поддержкой фоновых операций
С поддержкой мыши в xterm и консоли Linux
С поддержкой событий X11
С поддержкой интернационализации
С поддержкой многих кодировок
Data types: char 8 int 32 long 32 void * 32 off_t 64 ecs_char 8

The same problem.

I'll repeat:
on the screen flash several steps of connection (after entering correct pass)
fish:get information about...
fish:bla bla bla
fish: reading directory ....

oops... and nothing after. only flash cursor at the right bottom corner of screen ;(

With Respect.
MC User.

comment:6 in reply to: ↑ 4 Changed 8 years ago by gotar

Replying to Schneider:

I used search and I've saw both #2347 #2289 tickets. But my case different.

Next time mention it, otherwise you're just wasting other people time.

comment:7 in reply to: ↑ 5 ; follow-up: ↓ 10 Changed 8 years ago by gotar

Replying to Schneider:

> GNU Midnight Commander, версия 4.7.0.9
> Виртуальная файловая система: tarfs, extfs, cpiofs, ftpfs, fish, undelfs
> Со встроенным редактором

Use latin-based alphabet please, tickets written гражданским шрифтом may be not understood by someone and are mostly closed as invalid.

The same problem.

Check this one: ftp://ftp.pld-linux.org/dists/th/PLD/i686/RPMS/mc-4.7.3-2.i686.rpm

If it works then it's something in ubudubu build environment wrong, if the problem stays it's something with your environment.

comment:8 Changed 8 years ago by zaytsev

  • Cc zaytsev added
  • Version changed from 4.7.0.6 to 4.7.0.9

Gotar, chill out. I am the ubudubudu packager. The package is perfectly fine for me and numerous other users. OP better turn on logging on the ssh server to see what's actually going on.

comment:9 Changed 8 years ago by Schneider

Hmmm... Regardin environment.

  1. When I connecting from command line

$: ssh user@domain

From my computer to other comp. -connection opening fine

Only by mc hanged up.

  1. And more interesting that I can easy connect loopback by mc 4.7.0.9 (from my comp. to my computer.) My iptables rules are "accept" for all. If you thinking about such reason.

comment:10 in reply to: ↑ 7 Changed 8 years ago by Schneider

Check this one: ftp://ftp.pld-linux.org/dists/th/PLD/i686/RPMS/mc-4.7.3-2.i686.rpm

If it works then it's something in ubudubu build environment wrong, if the problem >stays it's something with your environment.

Checked. Nothing changed. What could be wrong with my environment? I've install last stable version of Ubuntu 10.10 one week ago.

comment:11 Changed 8 years ago by mcaccount

Hi,

I did have similar issue and I did 'fix' it (found a workaround) for me which is described in Ticket: #2031

comment:12 Changed 8 years ago by zaytsev

So what is the computer that you are connecting to? Which OS is it running?

comment:13 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to worksforme
  • Branch state set to no branch

Since no reply from reported during 11 months, closed.

comment:14 Changed 6 years ago by sorin

Please can you reopen the bug? I am constantly getting this behavior for years, it can be reproduced on OS X, Debian and Ubuntu.

Just connect using SSH and put the computer to sleep while in Ctrl-O mode, wait to the ssh connection to be dropped and voila...

You have an endless loop taking 200% CPU (I assume there are two threads, one being the terminal and one mc)

fish: failure
fish: Reading directory...

... only solution to kill the terminal session.

--
GNU Midnight Commander 4.8.8 on OS X 10.8 (brew)

comment:15 Changed 6 years ago by sorin

  • Status changed from closed to reopened
  • Cc sorin.sbarnea@… added
  • Priority changed from minor to major
  • Version changed from 4.7.0.9 to 4.8.8
  • Milestone changed from 4.7 to 4.8.9
  • Resolution worksforme deleted

comment:16 Changed 6 years ago by andrew_b

  • Milestone changed from 4.8.9 to Future Releases

comment:17 Changed 5 years ago by sorin

This bug is still present on Debian with mc:

GNU Midnight Commander 4.8.3
Built with GLib 2.24.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Note: See TracTickets for help on using tickets.