Ticket #2390 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

\0s in left panel after CmdInfo

Reported by: gotar Owned by: andrew_b
Priority: trivial Milestone: 4.8.0-pre1
Component: mc-core Version: 4.7.4
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master committed-stable

Description

Steps to reproduce:

  1. use xterm (I've got not UTF one),
  2. go to the right panel,
  3. ctrl-x i, ctrl-x i (enable and disable Info).

Result: right frame of left panel displays @ regardless of skin used (i.e. it doesn't depend on characters used for frames, in this case dvert). This doesn't happen on plain Linux console.

Attachments

mc-2390.png (7.8 KB) - added by gotar 8 years ago.

Change History

comment:1 Changed 8 years ago by gotar

It happens when terminal has odd count of columns, that's why I didn't reproduce it on my Linux console with even (but got 99 by default on xterm).

comment:2 Changed 8 years ago by gotar

And happens with Quick view (ctrl-x q) too.

comment:3 Changed 8 years ago by andrew_b

  • Milestone changed from 4.7 to 4.8

Would you show a screenshot illustrated this bug? I don't see any garbage symbols but I see wrong initialization of panel format after switch back to the file listing : columns have incorrect width.

Changed 8 years ago by gotar

comment:4 Changed 8 years ago by gotar

Sure, that's how it looks like just after it happens. Later it's being fixed entirely for a moment (when switching to altered panel) or partially ('@' - after viewing file in good panel).

comment:5 Changed 8 years ago by andrew_b

  • Keywords stable-candidate added
  • severity changed from no branch to on review
  • Milestone changed from 4.8 to 4.8.0-pre1

Well, I don't see the defect shown in the screenshot, but I fixed the incorrect listing format initialization.

Created 2390_panel_format_init branch. Parent branch is master.
Initial changeset:41b1c16e75b2e75dbed71ee4a09f9201bcc02a29

comment:6 Changed 8 years ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted

comment:7 Changed 8 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:8 Changed 8 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il

comment:9 Changed 8 years ago by angel_il

  • severity changed from on review to approved

comment:10 Changed 8 years ago by andrew_b

  • Status changed from accepted to testing
  • Keywords stable-candidate removed
  • Votes for changeset changed from slavazanko angel_il to committed-master committed-stable
  • Resolution set to fixed
  • severity changed from approved to merged

Merged to master.
changeset:d21eb43152af1aff992f86cd290ed161f916ee7b

git log --pretty=oneline 86d57f2..d21eb43

Cherry-picked to 4.7.5-stable
changeset:e199a8479119fb2556fd5308ad3e242776c1c0fc

git log --pretty=oneline adbf5f3..4b288c0

Cherry-picked to 4.7.0-stable
changeset:da9d40119f355db2a001eb60aedbe7ed37384deb

comment:11 Changed 8 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.