Ticket #2360 (closed defect: fixed)

Opened 9 years ago

Last modified 8 years ago

4.7.0.9 unable to show FTP listing if password contains #

Reported by: tmcdos Owned by:
Priority: major Milestone: 4.8.0-pre1
Component: mc-vfs Version: 4.7.0.9
Keywords: ftpfs password Cc: zaytsev
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

I am using version 4.6.1a in Fedora 6 (32-bit).
The ftpfs in MC won't enter any remote directory if the
password of the user contains a `#', and if this password
is in the ftp:// URL (i.e. ftp://user:#pass@host/dir).
When you try to enter a directory (pressing enter over
the dir), the pathname above the directory listing changes (adding new directory at the end) - but the listing remains the same.
If you would have MC to ask for the password (i.e.
ftp://user@host/dir), this won't happen.

OK, maybe # isn't allowed in the password part of the
URLs - but if I login through Internet Explorer or Opera, there is no problem.
It appears that MC logs in fine but navigation doesn't work as
it should, and also the directory listing is wrong - it shows files as folders (see attached screen shot).

Attachments

ftp_ok.png (55.5 KB) - added by tmcdos 9 years ago.
Proper FTP directory listing when password does not contain "#"
ftp_bad.png (56.0 KB) - added by tmcdos 9 years ago.
Wrong FTP directory listing, when password contains "#"

Change History

comment:1 Changed 49 years ago by slavazanko

  • Blocked By 2361 removed

(In #2361) Merge changeset:f2ebbd2eb4bd9e196963ecaf1f79b31986ad64ac

For getting list of commits in branch type:

git log --pretty=oneline fcfa76b..ef676d3

Changed 9 years ago by tmcdos

Proper FTP directory listing when password does not contain "#"

Changed 9 years ago by tmcdos

Wrong FTP directory listing, when password contains "#"

comment:1 Changed 9 years ago by tmcdos

This issue remains unsolved up to version 4.7.0.9 - I did not check above versions.

comment:2 Changed 9 years ago by zaytsev

  • Cc zaytsev added

I think it has nothing to do with FTP per se and it sounds just like if it was the same problem as with @ in the password field. VFS url parsing is broken.

comment:3 Changed 9 years ago by andrew_b

  • Blocked By 2361 added

comment:4 Changed 9 years ago by tmcdos

So - the problem will be left unresolved, is that what you mean ? And the silent recommendation is to avoid "#" symbols in FTP password, or to use a real FTP client ? I can leave with that. It just makes me needlessly unhappy.

comment:5 Changed 9 years ago by zaytsev

What I mean is what I mean: the origin of the problem is in the VFS layer and must be fixed in there. Don't needlessly venture into conspiracy theories and you will quickly realize how happier you are becoming.

comment:6 Changed 9 years ago by tmcdos

I apologize if my words are rude or offense - English is not my primary language. I just read ticket 2361 and now understand the situation much better.

comment:7 Changed 9 years ago by zaytsev

OK.

comment:8 Changed 8 years ago by slavazanko

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from 4.7 to 4.8.0-pre1

Was fixed as part of #2361

Note: See TracTickets for help on using tickets.