Ticket #2332 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

search match display in viewer suboptimal

Reported by: ossi Owned by:
Priority: minor Milestone:
Component: mcview Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

open /lib/libdbus-1.so.*, search for "glib" (well, that's the example which shows the problem with my particular libdbus build).
mcview apparently finds a match, but there is no sign of it on the screen.
my hypothesis is that the match is simply so deep into the "line" (actually, whatever in the binary mcview thinks is a line) that it was "wrapped out of the screen". as mcview clears the match highlight on the first cursor movement, even scrolling won't make the hit visible. the solution to that problem would be a more intelligent selection of the visible area after the hit, taking into account wrapping, formatting (which of course makes no sense in the first place when the file is binary), etc.

Change History

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version master deleted
  • Resolution set to duplicate

Duplicate of #2132.

comment:2 Changed 9 years ago by ossi

hmm, technically, it is a complementary problem, as i have wrapping enabled and thus the match disappears vertically, not horizontally.
but it seems plausible that the underlying problem is the same, indeed.

Note: See TracTickets for help on using tickets.