Ticket #2306 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

posix tar does not handle long filenames

Reported by: jendap Owned by:
Priority: major Milestone:
Component: mc-vfs Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Standard posix tar files have long filenames in extended headers (header "path=/some/very/long/filename").

The header is simply skipped now - see "Skip over pax extended header and global extended header records." in tar.c

Steps to reproduce the tar file:
echo "foo" >very_0_very_1_very_2_very_3_very_4_very_5_very_6_very_7_very_8_very_9_very_10_very_11_very_12_long_filename
tar cf foo.tar --format=posix very*

BTW: This is important especially in java world as there are deep directories and long filenames - virtually no tar file of any java project can be opened correctly in mc.

Change History

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.3 deleted
  • Resolution set to duplicate
  • Milestone 4.7 deleted

Duplicate of #2201.

Note: See TracTickets for help on using tickets.