Ticket #2301 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

Archive decompression directly to destination

Reported by: adamk Owned by:
Priority: major Milestone:
Component: mc-vfs Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

ATM, when copying files from archive, it works like this:

  1. file gets decompressed to a temporary directory
  2. file gets copied/moved from temporary to destination directory

This has two disadvantages:

  1. It requires space on temporary directory partition
  2. adds copy operation (if temp and dest are different partitions)

Ideal solution, file should be decompressed directly into destination directory, it will be faster and require no space on temp.

Change History

comment:1 Changed 9 years ago by andrew_b

  • Component changed from mc-core to mc-vfs

comment:2 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.0.6 deleted
  • Resolution set to duplicate
  • Milestone 4.7 deleted

Duplicate of #329.

Note: See TracTickets for help on using tickets.