Ticket #223 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

savannah: Crash when editing a file with a nonexistent syntax file

Reported by: styx Owned by:
Priority: major Milestone: 4.7
Component: mcedit Version: 4.6.1
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by slavazanko) (diff)

Original: http://savannah.gnu.org/bugs/?25438

bug #25438: Crash when editing a file with a nonexistent syntax file included by ~/.mc/cedit/Syntax

Submitted by:Dan Dascalescu <dandv>Submitted on: Fri 30 Jan 2009 06:29:57 AM UTC
Category: Editor Severity: 3 - Normal
Status: None Privacy: Public
Assigned to: None Open/Closed?: Open
Release: 4.6.0-pre1 Operating System:GNU/Linux

(-) Discussion

Fri 30 Jan 2009 06:29:57 AM UTC, original submission:

Looks like nobody is maintaining MC any longer, but I'll go ahead and submit a bug report anyway.

How to reproduce:

  1. Edit ~/.mc/cedit/Syntax and alter "file ..\*
    .lsm$ LSM\sFile" to "include this_doesnt_exist.syntax".
  1. Shift+F4, F2, bug.lsm
  1. Enjoy the crash

HTH,
Dan Dascalescu

Change History

comment:1 Changed 10 years ago by styx

Can't reproduce. Just syntax error. May be it is already fixed?

comment:2 Changed 10 years ago by styx

  • Description modified (diff)

comment:3 Changed 10 years ago by slavazanko

  • Description modified (diff)

comment:4 Changed 10 years ago by styx

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.