Ticket #2200 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

man2hlp at cross-compilation: must compiled for build, not target machine

Reported by: laborer Owned by:
Priority: minor Milestone:
Component: mc-core Version:
Keywords: man2hlp cross compilation ARM Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by andrew_b) (diff)

I have successfully configured mc for cross-compilation(ARM). Then i successfully build mc.
At "make install" stage i got an error:
make[4]: Entering directory `/tmp/mc/build/mc-4.7.2/doc/hlp'
make[4]: Nothing to be done for `install-exec-am'.
../../src/man2hlp ../../doc/man/mc.1 ./xnc.hlp mc.hlp
../../src/man2hlp: ../../src/man2hlp: не могу запустить бинарный файл
make[4]: [mc.hlp] Error 126 (ignored)
[sergey@aohost mc-4.7.2]$ file src/man2hlp
src/man2hlp: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.22, not stripped
My build system: Arch Linux i686.

Change History

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #45 and #1959.

See changeset:1959_cross_compile

Please use search before create new ticket.

comment:2 Changed 9 years ago by andrew_b

  • Version 4.7.2 deleted
  • Component changed from documentation to mc-core
  • Description modified (diff)
  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.