Ticket #2154 (closed enhancement: duplicate)

Opened 9 years ago

Last modified 9 years ago

Slightly increase mcedit file size limit in line with growing hardware capabilities

Reported by: zaytsev Owned by:
Priority: trivial Milestone:
Component: mcedit Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by zaytsev) (diff)

Forwarded from Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=369565

From: daniele giacomini <daniele@swlibero.org>
Subject: mcedit: wishing a bigger file size limit.
Date: Tue, 30 May 2006 18:19:27 +0200 (CEST)

Currently, mcedit is able to handle files with max 64 Mibyte size.
I wish that this limit will be doubled (128 Mibyte), with some little 
source changes, inside "edit/edit.h":

#define MAXBUFF 2048 /* instead of 1024 */
...
#define START_STACK_SIZE 64 /* instead of 32 */

I tryed to compile by myself and it seems to work.

Thank you for your attention.

I find it reasonable to increase the editor file size limit, because on my (3 years old) laptop, I have no problems with editing files of 64 MiB, so I guess 128 MiB won't hurt. This limit has been probably set when the hardware was much less powerful than now.

Change History

comment:1 Changed 9 years ago by zaytsev

  • Description modified (diff)

comment:2 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version master deleted
  • Resolution set to duplicate
  • Milestone 4.7 deleted

Duplicate of #1743.

Note: See TracTickets for help on using tickets.