Ticket #2131 (closed defect: invalid)

Opened 9 years ago

Last modified 9 years ago

E: mc: binary-or-shlib-defines-rpath ./usr/bin/mc /usr/lib

Reported by: zaytsev Owned by: andrew_b
Priority: major Milestone:
Component: mc-core Version:
Keywords: Cc: narcan
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

We can not upload the latest package to Debian because of a lintian warning:

zaytsev@davis:/var/cache/apt/archives$ lintian mc_3%3a4.7.0.3-1~karmic1~ppa2_amd64.deb 
E: mc: binary-or-shlib-defines-rpath ./usr/bin/mc /usr/lib

Possible solutions are here:

http://wiki.debian.org/RpathIssue

Adding --disable-rpath to ./configure does not work.

Could you please provide us with some other solution?

Thanks!

Change History

comment:1 Changed 9 years ago by zaytsev

  • Votes for changeset set to zaytsev
  • severity changed from no branch to on review

Branch: 2131_disable_rpath
Changeset: de326c16832397f8fe062872143453cb30c95a28

It works for me!

comment:2 Changed 9 years ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b

comment:3 Changed 9 years ago by zaytsev

The investigation revealed that this issue was caused by the fact that Slava generated the tarballs on the CentOS 5.4 machine with Autoconf 2.63 built from sources, but also with an old stock version of libtool that comes with CentOS.

This combination became confused by the way symlinks to lib are organized on Debian build hosts and wrongly added /usr/lib to RPATH as the result.

The solution is to generate the tarballs on a machine that has a most recent stable combination of autotools to date, for which a latest Fedora or Ubuntu machine might qualify.

If nobody has FC12 installed I can generate the tarballs for the next release on my Ubuntu Karmic machine which will be soon upgraded to Lucid as it comes out.

Therefore as the solution is found this ticket can be closed as fixed. Thanks to Slyfox for the help in determining the reason for the breakage!

comment:4 Changed 9 years ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset zaytsev deleted
  • severity changed from on review to no branch
  • Version master deleted
  • Milestone 4.7 deleted
  • Resolution set to invalid

comment:5 Changed 9 years ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.