Ticket #2113 (closed defect: duplicate)

Opened 14 years ago

Last modified 10 months ago

Get rid of unpacking arcives to temporary directory

Reported by: PiousMinion Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: Cc: god12@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

I have 3 storage devices on my system. A is for OS, B and C are for storage. If I have a very large(1GB+) archive that resides on C and try to extract it to a directory on B, it takes unnecessarily long. I believe this is because mc extracts to /tmp on A first and then copies to B.

This extra unneeded step causes the process to take twice as long which is a big deal when dealing with large archives. Also, it requires that A have enough space to hold the contents of the archive before copying.

Now, I'm sure there is some crazy reason for extracting to /tmp that I'm not aware of, but please, give us an option to not use /tmp. Even if it's a somewhat hidden option.

Change History

comment:1 Changed 13 years ago by andrew_b

  • Version changed from version not selected to master
  • Component changed from mc-core to mc-vfs
  • Summary changed from extraction takes unnecessarily long to Get rid of unpacking arcives to temporary directory

comment:2 Changed 12 years ago by andrew_b

  • Branch state set to no branch
  • Milestone changed from 4.7 to Future Releases

comment:3 Changed 10 years ago by god12

Any progress on this one? From the description it seems rather trivial - could you describe what's blocking it?

comment:4 Changed 8 years ago by god12

  • Cc god12@… added

comment:5 Changed 3 years ago by andrew_b

Ticket #3544 has been marked as a duplicate of this ticket.

comment:6 Changed 10 months ago by mivk

This can be a pretty serious bug.

I just tried to unzip 175 GB. on a machine where /tmp is on a 50 GB root filesystem with 18 GB free.

So it filled the root filesystem after which everything started to fail!

There really needs to be an option to unzip directly without going through /tmp first, or at least an option to set the temporary directory to a custom path.

comment:7 Changed 10 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #329.

Note: See TracTickets for help on using tickets.