Ticket #2051 (closed enhancement: duplicate)

Opened 9 years ago

Last modified 9 years ago

extfs performs absolutely poorly on solid archives

Reported by: birdie Owned by:
Priority: major Milestone:
Component: mc-vfs Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Testcase: create a solid RAR, ACE, or 7Z archive with a directory containing a thousand files in it.

Try to extract the last say 10 files from this archive or a directory containing all the files.

urar, u7z, and uace will unpack this archive 10 or 1000 times to extract 10 files or the whole archive and that will take an insane amount of time.

Midnight Commander should be rewritten in such a way so that extfs handlers could prepare a list of files and pass this list to archiver.

Change History

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-vfs
  • Priority changed from critical to major
  • Version version not selected deleted
  • Milestone 4.7 deleted
  • Resolution set to duplicate

Duplicate of #3.

Note: See TracTickets for help on using tickets.