Ticket #2023 (closed defect: invalid)

Opened 9 years ago

Last modified 9 years ago

GLib-ERROR **: gmem.c:175: failed to allocate 18446744073709551615 bytes

Reported by: lvv Owned by:
Priority: major Milestone: 4.7
Component: mc-core Version: 4.7.0.2
Keywords: glib 64 Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

I see this error with mc-4.7.0.2 on gentoo x86_64. I've tied on/off all use flags and to compile from source. Error always the same.

~> uname -a
Linux ahp 2.6.30.9 #2 SMP Sun Jan 31 21:47:23 EET 2010 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel? GNU/Linux

~> eix dev-libs/glib
dev-libs/glib

Installed versions: 1.2.10-r5(1)(11:53:42 PM 06/14/2009)(-hardened)

2.22.4(2)(09:55:46 PM 01/29/2010)(doc fam -debug -hardened -selinux -xattr)

~> ldd /usr/local/bin/mc

linux-vdso.so.1 => (0x00007fffc8dff000)
libgpm.so.1 => /lib/libgpm.so.1 (0x00007f1b4b4f7000)
libslang.so.2 => /usr/lib/libslang.so.2 (0x00007f1b4b172000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00007f1b4af6e000)
libdl.so.2 => /lib/libdl.so.2 (0x00007f1b4ad6a000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f1b4aa72000)
libc.so.6 => /lib/libc.so.6 (0x00007f1b4a719000)
libncurses.so.5 => /lib/libncurses.so.5 (0x00007f1b4a4c3000)
libm.so.6 => /lib/libm.so.6 (0x00007f1b4a240000)
/lib64/ld-linux-x86-64.so.2 (0x00007f1b4b6fe000)

~> l /usr/lib/libglib-2*
-rw-r--r-- 1 root root 1.8M 2010-01-29 21:55 /usr/lib/libglib-2.0.a
-rw-r--r-- 1 root root 953 2010-01-29 21:55 /usr/lib/libglib-2.0.la
lrwxrwxrwx 1 root root 23 2010-01-29 21:55 /usr/lib/libglib-2.0.so -> libglib-2.0.so.0.2200.4*
lrwxrwxrwx 1 root root 23 2010-01-29 21:55 /usr/lib/libglib-2.0.so.0 -> libglib-2.0.so.0.2200.4*
-rwxr-xr-x 1 root root 989K 2010-01-29 21:55 /usr/lib/libglib-2.0.so.0.2200.4*

Attachments

dot-mc.tgz (16.8 KB) - added by lvv 9 years ago.
".mc/" dir where "ini" file have extraneous "======"

Change History

comment:1 follow-up: ↓ 2 Changed 9 years ago by andrew_b

Please desrcibe step-by-step how to reproduce this bug.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 4 Changed 9 years ago by lvv

I just type "mc" at command prompt, press enter and immediately see this error. Reproducible always.

~> mc

GLib-ERROR : gmem.c:175: failed to allocate 18446744073709551615 bytes

aborting...

Aborted

comment:3 Changed 9 years ago by lvv

BTW:

~> wcalc -h 18446744073709551615

0xffffffffffffffff

comment:4 in reply to: ↑ 2 ; follow-up: ↓ 5 Changed 9 years ago by slyfox

Replying to lvv:

I just type "mc" at command prompt, press enter and immediately see this error. Reproducible always.

~> mc

GLib-ERROR : gmem.c:175: failed to allocate 18446744073709551615 bytes

aborting...

Aborted

My setup is mostly the same, but I use git ebuild and don't see such problems. Maybe, something like old ~/.mc/ content makes mc upset. You might try to verify it by moving temporarily ~/.mc/ somewhere, then rollback and proceed further investigation.
Maybe, it will be enough to send us contents of ~/.mc/.

Wonder, if -git one breaks for you. (In case you'll give it a try: http://www.midnight-commander.org/browser/contrib/dist/gentoo/README)

Would be nice to see whole stack trace for this breakage (might need to reemerge mc with FEATURES=debug). Either by attaching gdb:

$ gdb mc
> bt full

or by tracing it with valgrind:

$ valgrind --log-file=a.log --track-origins=yes mc

Thanks!

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 9 years ago by lvv

It was .mc/ini
It has extranious line having just "======" - leftover from SVN merge.
Thanks for suggestion and troubleshooting.

comment:6 in reply to: ↑ 5 Changed 9 years ago by slyfox

Replying to lvv:

It was .mc/ini
It has extranious line having just "======" - leftover from SVN merge.
Thanks for suggestion and troubleshooting.

Tried to add ====== at the beginning of ini file and at the section start. Unable to reproduce failure. May I ask you to attach your ini file to this bug?

Changed 9 years ago by lvv

".mc/" dir where "ini" file have extraneous "======"

comment:7 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid

I believe it is a bug of GLib, not MC.

Note: See TracTickets for help on using tickets.