Ticket #2002 (closed defect: wontfix)

Opened 10 years ago

Last modified 10 years ago

Find File scrollbar looses 'arrow'

Reported by: gotar Owned by:
Priority: minor Milestone:
Component: mc-core Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by andrew_b) (diff)

There is a scrollbar in "Find File" results dialog. When position indicator (asterisk) 'covers' an arrow (^ or v) and then uncovers it (by moving back, not wrapping around to the other end), the arrow doesn't reappear until indicator is moved a few lines further (to make the results scroll at least one line).

Also note, that utmost positions of asterisk in fact don't cover arrows, so either the arrows shouldn't disappear in first place, or asterisk mark should have one character each side wider movement.

Change History

comment:1 Changed 10 years ago by gotar

The same happens in 4.6.1 and 4.6.2.

comment:2 Changed 10 years ago by andrew_b

  • Description modified (diff)

comment:3 Changed 10 years ago by gotar

Looking through the code I've found out, that this is intended behaviour (arrow shows if there's more data, i.e. something to scroll). Maybe it would be less misleading if the arrow changes to some other character instead of diappearing, otherwise please close this ticket.

comment:4 Changed 10 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to wontfix

I believe is not a critical issue. Scrollbar waits for it reimplementation (#1483).

comment:5 Changed 10 years ago by andrew_b

  • Version 4.7.0.2 deleted
  • Milestone 4.7 deleted
Note: See TracTickets for help on using tickets.