Ticket #1964 (closed defect: worksforme)

Opened 9 years ago

Last modified 9 years ago

Segfault in extfs.c

Reported by: antiguru Owned by:
Priority: major Milestone: 4.7
Component: mc-vfs Version: 4.7.0
Keywords: Cc: narcan, winnie, zaytsev,
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Here is the backtrace:
(gdb) where
#0 0xb7d3e418 in strcmp () from /lib/i686/cmov/libc.so.6
#1 0x080b970a in extfs_which (me=0x81116a0, path=0x0) at extfs.c:1380
#2 0x080ba25b in extfs_get_path_mangle (me=0x81116a0,

inname=0x81a9058 "/var/cache/apt/archives/ibm-cck_1.6.0-4_all.deb#deb/CONTENTS/usr/lib/firefox-addons/extensions/IBM-cck@…", archive=<value optimized out>, do_not_open=0) at extfs.c:465

#3 0x080bb020 in extfs_internal_stat (me=0x81116a0, path=<value optimized out>, buf=0xbfffe5e8, resolve=0) at extfs.c:968
#4 0x080b6d73 in mc_lstat (filename=0x8149583 "IBM-cck@…", buf=0xbfffe5e8) at vfs.c:899
#5 0x08078123 in handle_dirent (list=<value optimized out>, filter=0x811e240 "uzip", dp=0x8149570, buf1=0xbfffe5e8, next_free=1,

link_to_dir=0xbfffe64c, stale_link=0xbfffe648) at dir.c:302

#6 0x08078c53 in do_load_dir (

path=0x815b400 "/var/cache/apt/archives/ibm-cck_1.6.0-4_all.deb#deb/CONTENTS/usr/lib/firefox-addons/extensions", list=0x815b3f0,
sort=0x8078e10 <sort_name>, lc_reverse=0, lc_case_sensitive=1, exec_ff=0, filter=0x0) at dir.c:433

#7 0x0808f32f in _do_panel_cd (panel=0x815b3c0, new_dir=<value optimized out>, cd_type=<value optimized out>) at main.c:496
#8 0x0808f647 in do_panel_cd (panel=0x815b3c0, new_dir=0x8158508 "..", cd_type=cd_exact) at main.c:518
#9 0x0808f691 in do_cd (new_dir=0x8158508 "..", exact=cd_exact) at main.c:527
#10 0x0805593f in do_enter_on_file_entry (fe=0x81808c4) at screen.c:2313
#11 0x08057f04 in do_enter (w=0x815b3c0, msg=WIDGET_KEY, parm=10) at screen.c:2365
#12 cmd_do_enter (w=0x815b3c0, msg=WIDGET_KEY, parm=10) at screen.c:2625
#13 panel_execute_cmd (w=0x815b3c0, msg=WIDGET_KEY, parm=10) at screen.c:2654
#14 panel_key (w=0x815b3c0, msg=WIDGET_KEY, parm=10) at screen.c:2777
#15 panel_callback (w=0x815b3c0, msg=WIDGET_KEY, parm=10) at screen.c:2861
#16 0x08051185 in send_message (h=0x8158078, key=10, event=0xbffff884) at ../src/tty/../../src/dialog.h:236
#17 dlg_key_event (h=0x8158078, key=10, event=0xbffff884) at dialog.c:719
#18 dlg_process_event (h=0x8158078, key=10, event=0xbffff884) at dialog.c:823
#19 0x080515d1 in frontend_run_dlg (h=0x8158078) at dialog.c:855
#20 run_dlg (h=0x8158078) at dialog.c:870
#21 0x0808e62d in setup_panels_and_run_mc () at main.c:1790
#22 do_nc () at main.c:1888
#23 0x0808eea5 in main (argc=1, argv=0xbffffb14) at main.c:2215

I have both failing file and core dump, if it is required. It seems like the problem is in vfs_split (inname, &local, &op); in function extfs_get_path_mangle.
This problem occurred with MC 4.7.0 from Debian Testing.

Kind regards,
Moritz

Change History

comment:1 Changed 9 years ago by antiguru

  • Version changed from version not selected to 4.7.0

comment:2 Changed 9 years ago by andrew_b

deb support is broken.

comment:3 Changed 9 years ago by slavazanko

  • Cc narcan, winnie, zaytsev added

Yes, need to review DEB package. Yury Zaytsev reported about broken directory highlight into mc. May be, this is have same root of trouble...

comment:4 follow-up: ↓ 5 Changed 9 years ago by zaytsev

Actually it works very well for me on mc 4.7.0.1 (current package trunk in Debian). I can not test on 4.7.0, but anyway I don't believe that it's a packaging bug.

The issue with file highlighting was due to an unpackaged file / was fairly trivial to fix and has nothing to do with extfs.

The questions that OP should answer is

1) Whether he is able to reproduce it on latest master;
2) Whether it consistently happens on all debs or just some of them.

comment:5 in reply to: ↑ 4 Changed 9 years ago by antiguru

I also use mc 4.7.0-1. Opening all other deb files works well. It is only one specific file, probably the file is broken. Still, I think, mc should not crash if a broken deb file is being opened.

Contact me if you require the file for testing purposes.

I tried to compile mc from GIT, bit it takes too much time right now to test if the problem still occurs.

comment:6 Changed 9 years ago by zaytsev

Can you post a link to this mysterious deb?

comment:7 Changed 9 years ago by antiguru

Send me your email to antiguru at gmail dot com. I can't put it here.

comment:8 Changed 9 years ago by zaytsev

Done.

comment:9 Changed 9 years ago by zaytsev

Very funny! I could reproduce this on 4.7.0.1. If I directly go into the archive and then browse the deb it works, but shows a broken link, otherwise it crashes. We will look into this.

comment:10 Changed 9 years ago by zaytsev

Works for me on 4.7.0.1-48-g86251db (stable branch). I guess it's because we reverted the split_url patch that were causing more problems than it solved.

comment:11 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.