Ticket #1962 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

Quick move non-intelligent behaviour

Reported by: igorp1024 Owned by:
Priority: major Milestone:
Component: mc-core Version:
Keywords: Cc: ip1024@…
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Quick move not always work.

Use case:
For example, we have the following directories hierarchy (on the same mountpoint):
~/path1/dirA
~/path2
dirA contains files/subdirs
path1 is opened on one panel and path2 is opened on the opposite.

By putting cursor on dirA and pressing F6 it's being moved via quickmove.

Problem:
If there is an existing dirA on ~/path2 then moving is being performed by reading source file and writing to the target file.
It even could make the mountpoint to be out of free space, because mc deletes directory contents only after successful directory move.

Proposal:
Always to check the ability to quickmove the files.

Change History

comment:1 Changed 9 years ago by igorp1024

  • Cc ip1024@… added

comment:2 Changed 9 years ago by ossi

duplicate of ticket #20

comment:3 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version version not selected deleted
  • Resolution set to duplicate
  • Milestone 4.7.1 deleted
Note: See TracTickets for help on using tickets.