Ticket #1958 (closed defect: worksforme)

Opened 9 years ago

Last modified 9 years ago

ftp fails with tsocks

Reported by: NNemec Owned by: NNemec
Priority: minor Milestone: 4.7
Component: mc-vfs Version: 4.7.0.1
Keywords: FTP vfs Cc: zaytsev
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

My machine has no direct internet connection, so I am using ssh-tunnel with tsocks for everything. So far, nearly every program has worked fine. In MC, however, the FTP vfs does not work. I set the option for passive FTP, but I still get the same error "Permission denied (13)" for two different ftp connections that work perfectly from another, directly connected machine.

The SSH vfs works perfectly.

My guess is that MC uses some built-in routine for making the FTPfs connection rather than the standard libc functions that are replaced by the tsocks prelink.

I believe this error only came up recently, but I cannot say for sure.

Change History

comment:1 Changed 9 years ago by andrew_b

  • Component changed from mc-core to mc-vfs

comment:2 Changed 9 years ago by zaytsev

  • Cc zaytsev added

Does the patchset from #121 fix it for you?

comment:3 Changed 9 years ago by NNemec

  • Status changed from new to accepted
  • Owner set to NNemec

comment:4 Changed 9 years ago by NNemec

  • Status changed from accepted to testing
  • Resolution set to worksforme

My local setup has changed so I cannot reproduce the problem any more. I declare the matter as resolved for the moment. If someone experiences the same problem, please reopen.

comment:5 Changed 9 years ago by andrew_b

  • Status changed from testing to closed

OK. Closed.

Note: See TracTickets for help on using tickets.