Ticket #195 (closed enhancement: wontfix)

Opened 10 years ago

Last modified 9 years ago

(mandriva) add ctrl-l as hotkey for quick-chdir

Reported by: metux Owned by: slavazanko
Priority: major Milestone: 4.7
Component: mc-core Version: 4.6.1
Keywords: mandriva Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Change History

comment:1 Changed 10 years ago by metux

  • Type changed from defect to enhancement

comment:2 Changed 10 years ago by andrew_b

It's a bad idea. Currentrly Ctrl-l hotkey is used to refresh the screen (see src/screen.c(dialog_handle_key)).

comment:3 Changed 10 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted

It's a bad idea.

+1. In editor CTRL+L used too.

refresh the screen

'Repaint' more exactly. :)

comment:4 Changed 10 years ago by slavazanko

  • Status changed from accepted to testing
  • Resolution set to invalid

comment:5 Changed 10 years ago by slavazanko

  • Keywords review removed

comment:6 Changed 10 years ago by winnie

  • Status changed from testing to closed

comment:7 follow-up: ↓ 8 Changed 10 years ago by Adam Williamson

  • Status changed from closed to reopened
  • Resolution invalid deleted

On Sun, 2009-01-18 at 21:22 +0000, Ticket System wrote:

#195: (mandriva) add ctrl-l as hotkey for quick-chdir


Reporter: metux | Owner: slavazanko

Type: enhancement | Status: closed

Priority: major | Milestone: 4.7

Component: mc-core | Version: 4.6.1

Resolution: invalid | Keywords: mandriva

Blocking: | Blockedby:


Changes (by winnie):

  • status: testing => closed

On this one - I don't think closing it because the shortcut I happened
to choose is a bad one is a valid resolution. The *reason* this patch
was introduced is still valid. See the original Mandriva bug:

http://qa.mandriva.com/show_bug.cgi?id=44201

the problem is that the ctrl-\ combination is unavailable on some
keyboard layouts. This problem is still a valid one. It would be better
to re-open the bug and pick some other available combination, rather
than just not address the problem.

See the discussion there on trying to find an available combo, also.

comment:8 in reply to: ↑ 7 Changed 10 years ago by andrew_b

Replying to Adam Williamson:

pick some other available combination, rather than just not address the problem.

Maybe Alt-/

comment:9 Changed 10 years ago by styx

I think we shouldn't to guess now which combo to use. At first we need to release #212 and then create some predefined schemes for tree view and editor. Of course we will have legacy bindings and for editor something like: emacs/vim/etc.

comment:10 Changed 10 years ago by Enrico Weigelt

Perhaps we should think about configurable shortcuts in general ?
(maybe for 4.7 ?)

comment:11 Changed 10 years ago by winnie

  • Blocked By 212 added

Please have a look on #212. This is about configurable shortcuts in general.

comment:12 Changed 10 years ago by styx

  • Status changed from reopened to closed
  • Resolution set to wontfix

comment:13 Changed 10 years ago by slavazanko

  • Blocked By 212 removed
Note: See TracTickets for help on using tickets.