Ticket #1928 (closed defect: fixed)

Opened 9 years ago

Last modified 7 years ago

initially not at start of a line

Reported by: ossi Owned by:
Priority: minor Milestone: 4.7
Component: mcview Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

the viewer remembers the current file position in a file as an offset.
now, when the file changes before the file is viewed the next time, that offset might refer anywhere. previously, mcview would have fixed that offset by tracking back to the beginning of the line the offset points into. now, it will just start showing the file right at the saved offset. the effect is that scrolling up will first cause only the first line to "jump", back to the actual beginning of the line.

Change History

comment:1 Changed 8 years ago by andrew_b

  • Branch state set to no branch

Is this bug still actual? I am unable to reproduce it in recent master. It seems, the bug was fixed in changeset:b1de9bbd809c85c7022a96caea14200d9fa4692f.

comment:2 Changed 7 years ago by ossi

i didn't notice it in quite a while, so i suppose your hypothesis is accurate.

comment:3 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to fixed

Ok. Thanks.
Closed.

Note: See TracTickets for help on using tickets.