Ticket #1927 (closed defect: duplicate)

Opened 10 years ago

Last modified 9 years ago

missing-g_free-in-vfs-extfs.c

Reported by: vit_r Owned by:
Priority: trivial Milestone:
Component: mc-vfs Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by andrew_b) (diff)

in vfs-extfs.c funcs

extfs_readlink(), extfs_unlink(), extfs_mkdir() and extfs_rmdir()
have 'char *q;' which shouid be freed after use

Attachments

1927-missing-g_free-in-vfs-extfs.c.patch (1.8 KB) - added by vit_r 10 years ago.
four missing g_free(q) in vfs/extfs.c

Change History

Changed 10 years ago by vit_r

four missing g_free(q) in vfs/extfs.c

comment:1 follow-up: ↓ 2 Changed 10 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.0.1 deleted
  • Resolution set to duplicate
  • Description modified (diff)
  • Milestone 4.7 deleted

Why do you propose this wrong patch again?

Closed as duplicate of 1896.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 10 years ago by vit_r

Replying to andrew_b:

Why do you propose this wrong patch again?

Closed as duplicate of 1896.

It looked for me that 1896 was closed because of bad description.
But what about four missing g_free(q) in vfs/extfs.c ?
Are they needed or not ?
Can You be so kind to make it clear ?
Please

comment:3 in reply to: ↑ 2 Changed 10 years ago by vit_r

Replying to vit_r:

Replying to andrew_b:

Why do you propose this wrong patch again?

Closed as duplicate of 1896.

It looked for me that 1896 was closed because of bad description.
But what about four missing g_free(q) in vfs/extfs.c ?
Are they needed or not ?
Can You be so kind to make it clear ?
Please

Ohhh..!!!

i've got the point where i was wrong.

No g_free() is missing here

Sorry for disturbance

Note: See TracTickets for help on using tickets.