Ticket #1890 (reopened enhancement)

Opened 12 years ago

Last modified 7 months ago

shift+f5 and shift+f6 doesn't work in konsole

Reported by: tectep Owned by:
Priority: minor Milestone: Future Releases
Component: mc-tty Version: 4.8.11
Keywords: shift f5 f6 Cc: zaytsev, lzsiga@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

learn keys shows that shift+f5 corresponds to f17 (should be f15) and shift+f6 corresponds to f18 (should be f16). Version 4.6.1 has no such defect, so it looks like regression in mc.

Change History

comment:1 Changed 12 years ago by angel_il

please do (in konsole):
$ cat
press shift-f5, shift-f6, shift-f7

copy-paste result in this ticket.

comment:2 Changed 12 years ago by zaytsev

zaytsev@mypride:~/Desktop$ cat
^[[15;2~^[[17;2~^[[18;2~
Last edited 8 months ago by andrew_b (previous) (diff)

comment:3 Changed 12 years ago by tectep

i've tested version 4.7.0_pre1 - it works fine
but in 4.7.0_pre2 shift+f6 and shift+f5 hotkeys stopped to work

p.s.

# cat
^[[15;2~^[[17;2~^[[18;2~
Last edited 8 months ago by andrew_b (previous) (diff)

comment:4 Changed 12 years ago by zaytsev

I think it has to do with missing keybindings... Did you test on master???

comment:5 Changed 12 years ago by tectep

tested on master commit fc08c10012dec2ccecd4889d601446f94546eb1b
it works! So I'm waiting for pre5 )

comment:6 Changed 12 years ago by angel_il

  • Milestone changed from 4.7 to 4.7.0

comment:7 Changed 12 years ago by angel_il

please say result

echo $TERM

comment:8 Changed 12 years ago by tectep

# echo $TERM
xterm

comment:9 Changed 12 years ago by zaytsev

Ilya, I guess we can close it now as invalid since it was due to the missing keybindings in master and user reports that testing on master fixes his issue???

comment:10 Changed 12 years ago by zaytsev

  • Cc zaytsev added

comment:11 Changed 12 years ago by tectep

I think changset 91c7dbb71c9c8a5792287de3f70553076d94602b fixed this issue. Tommorow I try to apply this patch to pre4 to say precisely.
IMHO now this issue can be closed.

comment:12 Changed 12 years ago by zaytsev

  • Status changed from new to closed
  • Resolution set to invalid

I'm not sure, but it's now invalid anyway :-)

comment:13 Changed 8 years ago by lzsiga

  • Status changed from closed to reopened
  • Cc lzsiga@… added
  • Resolution invalid deleted
  • Component changed from mc-core to mc-config-ini
  • Version changed from 4.7.0-pre4 to 4.8.11
  • Branch state set to no branch
  • Milestone changed from 4.7.0 to 4.8
  • Type changed from defect to enhancement

Sorry if it isn't the right place, but actually there is a little problem with konsole: Shift+F5 (ESC[15;2~) act as F17 -- It is correct in general, but bad for mc-users who expect Shift+F5 to be F15 like it is in xterm and other common emulators.

The solution seems to be simple: this part should be added into file mc.lib:

 [terminal:konsole]
 copy=xterm

 [terminal:konsole-256color]
 copy=xterm

Note:
Why do I need this: I'm the maintainer of a terminal-emulator (dtelnet), and I would like to offer my users a terminal-type, which is suitable for linux. The requirements are:

  • in terminfo, 'kbs' is 'Ctrl+?' not 'Ctrl+H' (xterm is gone)
  • it has a -256color variant
  • mc supports it, including mouse and special keys like Shift+Arrows, Ctrl+Home etc

konsole seems to be suitable, except for this little change.

Last edited 7 months ago by andrew_b (previous) (diff)

comment:14 Changed 6 years ago by andrew_b

  • Milestone changed from 4.8 to Future Releases

comment:15 Changed 10 months ago by andrew_b

  • Component changed from mc-config-ini to mc-tty

comment:16 Changed 8 months ago by andrew_b

Ticket #2064 has been marked as a duplicate of this ticket.

comment:17 Changed 7 months ago by zaytsev

Andrew, should we just add it to mc.lib like we've done in #4149 and be done with it?

comment:18 Changed 7 months ago by andrew_b

I'm not a KDE user and I have some problems with testing of proposed solution.

comment:19 Changed 7 months ago by ossi

upstream konsole always sets TERM=xterm-256color, so things work just fine. i suppose some more pedantic distributors patch it to have an own terminfo entry; forcibly mapping it back to xterm in mc should work then.

Last edited 7 months ago by ossi (previous) (diff)
Note: See TracTickets for help on using tickets.