Ticket #1888 (closed defect: worksforme)

Opened 9 years ago

Last modified 3 years ago

missing special characters

Reported by: s01ja Owned by:
Priority: major Milestone:
Component: mcedit Version: 4.7.0-pre4
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

editing the misc/skin/*.ini in the GIT mc i noticed that all the characters are just '.'
changes to the LANG environment variable did not work as expected
edit ini in 4.6.1 looks fine
all input is '.' too weird...

this problem also appears in mcview

LANG=en_US.UTF-8 ./src/mc -V
GNU Midnight Commander 4.7.0-pre4-206-g8791773
Virtual File System: tarfs, extfs, cpiofs, ftpfs, fish, smbfs
With builtin Editor
Using system-installed S-Lang library with terminfo database
With subshell support as default
With support for background operations
With mouse support on xterm
With support for X11 events
With internationalization support
With multiple codepages support
Data types: char 8 int 32 long 32 void * 32 off_t 64 ecs_char 8

editor seems not to work at all - thats the price for bleeding edge software and i like it :)

Attachments

mc-skin-special-symbols.png (14.3 KB) - added by s01ja 9 years ago.
left: git, right: 461
mc.PNG (18.7 KB) - added by angel_il 9 years ago.
latest mc from git

Change History

comment:1 Changed 9 years ago by angel_il

please attache screenshot

Changed 9 years ago by s01ja

left: git, right: 461

Changed 9 years ago by angel_il

latest mc from git

comment:2 Changed 9 years ago by angel_il

try compile with flag --enable-charset

comment:3 in reply to: ↑ description Changed 9 years ago by andrew_b

Replying to s01ja:

edit ini in 4.6.1 looks fine

What 4.6.1 do you mean exactly? Is it clean MC or MC from any distro with a lot of patches?

comment:4 Changed 9 years ago by s01ja

What 4.6.1 do you mean exactly?

edubuntu netbook something (lpia)

enable-charset is [yes] in configure. rebuilding with option set did not change things

comment:5 Changed 7 years ago by andrew_b

  • Branch state set to no branch
  • Milestone changed from 4.7 to Future Releases

What about this bug? Is it still actual in recent releases 4.8.0 and 4.7.5.5?

comment:6 Changed 7 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to worksforme

comment:7 Changed 7 years ago by c0da

still got trouble displaying utf8 characters when LANG is not set correctly. using the right terminal and LANG=en_US.utf8 mcedit can handle hebrew characters.
this ticket was intended for the specific (-pre) version. the problem was fixed a long time ago.

comment:8 Changed 3 years ago by zaytsev

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.