Ticket #1832 (closed enhancement: duplicate)

Opened 9 years ago

Last modified 2 years ago

F2_MultiComment__Del-Uncomm__C-s_Save__M-y_TSyntax

Reported by: vit_r Owned by: vit_r
Priority: minor Milestone:
Component: mcedit Version: 4.7.0-pre4
Keywords: Cc: zaytsev
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by zaytsev) (diff)

While pressing F2 comments lines (cursor can start anywhere)

(excl ELF)
';' - "*.[s,S]" filenames
'' - "*.[h,H,c,C]" | "*.[c,C]??" filenames
'#' - } else {

To uncomment first press Home to move curs to bol
then pressing Delete uncomments lines accordingly.

C-s was for CK_Toggle_Syntax which now is on Alt-y, so
C-s does CK_Save as in KWrite

Hope someone will like to use it

Anyway it proved to be convenient and at the moment

it is my thanks to dev-team for great efforts


building the Best file manager.

Vit

ps

"Comment(by zaytsev): No print screen please..."
Mr. zaytsev !
It is fine in X also now

pps

"Comment(by andrew_b): ... Solution must be more general and flexible."
Mr. andrew_b !
If an expert would agree to guide me I'll try my best
to remake it so it will enrich mc one day !



2009-11-17

Change History

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

WTF??? Closed as wonfix and duplicate of #1819.

comment:2 Changed 9 years ago by zaytsev

  • Cc andrew_b added
  • Description modified (diff)

comment:3 Changed 9 years ago by zaytsev

  • Cc zaytsev added

And

comment:4 Changed 9 years ago by zaytsev

Andrew, I think that comment / uncomment is not bad, but it should be more general (e.g. not only C/C++, but also TeX, Python etc.)... why wouldn't we leave this open for future releases, maybe one day Ilya would want to take care of it, or the original author will improve it until it gets the acceptable shape.

comment:5 Changed 2 years ago by andrew_b

  • Cc andrew_b removed
  • Branch state set to no branch
  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.