Ticket #1790 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

mc crashes on start

Reported by: a.panov Owned by: slavazanko
Priority: critical Milestone: 4.7.0
Component: mc-core Version: 4.7.0-pre4
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description (last modified by slyfox) (diff)

mc новее, чем 4.7.0-pre3 падает при запуске.

вывод gdb:

Core was generated by `mc'.
Program terminated with signal 11, Segmentation fault.
[New process 20766]
#0  0x0000000000424fb8 in panel_new_with_dir (panel_name=<value optimized out>, wpath=0x0)
    at screen.c:1314
1314        panel->count =
(gdb) where 
#0  0x0000000000424fb8 in panel_new_with_dir (panel_name=<value optimized out>, wpath=0x0)
    at screen.c:1314
#1  0x000000000045834f in restore_into_right_dir_panel (lc_index=<value optimized out>, 
    from_widget=<value optimized out>) at layout.c:1156
#2  0x000000000045870c in set_display_type (num=1, type=0) at layout.c:926
#3  0x000000000045a1da in create_panels () at main.c:959
#4  0x000000000045a310 in setup_mc () at main.c:1430
#5  0x000000000045c733 in main (argc=1, argv=0x7fff96a1cb58) at main.c:1872

вывод Valgrind:

==20852== Memcheck, a memory error detector
==20852== Copyright (C) 2002-2009, and GNU GPL'd, by Julian Seward et al.
==20852== Using Valgrind-3.5.0 and LibVEX; rerun with -h for copyright info
==20852== Command: mc
==20852== 
==20852== Warning: invalid file descriptor -1 in syscall close()
==20852== Warning: invalid file descriptor -1 in syscall close()
==20852== Invalid read of size 8
==20852==    at 0x424FB8: panel_new_with_dir (screen.c:1314)

==20852==    by 0x    4E: restore_into_right_dir_panel (layout.c:1156)
==20852==    by 0x45870B: set_display_type (layo    :926)
==20852==    by 0x45A1D9: create_panels (main.c:959)
==20852==    by 0x45A30F: setup_mc (mai    1430)
==20852==    by 0x45C732: main (main.c:1872)
==20852==  Address 0x38 is not stack'd, malloc'd or (recently) free'd
==20852== 
==20852== 
==20852== Process terminating with default action of signal 11 (SIGSEGV)
==20852==  Access not within mapped region at address 0x38
==20852==    at 0x424FB8: panel_new_with_dir (screen.c:1314)
==20852==    by 0x45834E: restore_into_right_dir_panel (layout.c:1156)
==20852==    by 0x45870B: set_display_type (layout.c:926)
==20852==    by 0x45A1D9: create_panels (main.c:959)
==20852==    by 0x45A30F: setup_mc (main.c:1430)
==20852==    by 0x45C732: main (main.c:1872)
==20852==  If you believe this happened as a result of a stack
==20852==  overflow in your program's main thread (unlikely but
==20852==  possible), you can try to increase the size of the
==20852==  main thread stack using the --main-stacksize= flag.
==20852==  The main thread stack size used in this run was 8388608.
==20852== 
==20852== HEAP SUMMARY:
==20852==     in use at exit: 493,765 bytes in 1,939 blocks
==20852==   total heap usage: 16,352 allocs, 14,413 frees, 4,591,238 bytes allocated
==20852== 
==20852== LEAK SUMMARY:
==20852==    definitely lost: 66 bytes in 3 blocks
==20852==    indirectly lost: 240 bytes in 10 blocks
==20852==      possibly lost: 123,648 bytes in 1,339 blocks
==20852==    still reachable: 369,811 bytes in 587 blocks
==20852==         suppressed: 0 bytes in 0 blocks
==20852== Rerun with --leak-check=full to see details of leaked memory
==20852== 
==20852== For counts of detected and suppressed errors, rerun with: -v
==20852== ERROR SUMMARY: 1 errors from 1 contexts (suppressed: 5 from 5)
Ошибка сегментирования

Система - Slackware64 13.0, LC_ALL=ru_RU.KOI8-R, mc сконфигурирован с опциями --enable-extcharset --enable-netcode --enable-background --enable-charset --with-gpm-mouse --with-vfs-undelfs --with-x --with-vfs --with-samba --with-configdir=/etc/samba --with-codepagedir=/etc/codepages, падает и в консоли, и в терминалах X.

Attachments

panels.ini (876 bytes) - added by a.panov 10 years ago.
panels.ini
mc-bt.txt (3.4 KB) - added by a.panov 10 years ago.
output from gdb bt full

Change History

comment:1 Changed 10 years ago by andrew_b

Unfortunately, cannot reproduce. Could you built mc with gebug info and attach 'gdb bt' and 'gdb bt full' outputs to the this ticket. Detailed info see in ru/tracingCrash

comment:2 Changed 10 years ago by zaytsev

--with-samba ???

comment:3 Changed 10 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted

a.panov: Please, show here output of:

cat ~/.mc/panels.ini

comment:4 Changed 10 years ago by slavazanko

  • severity changed from no branch to on review
  • Milestone changed from 4.7 to 4.7.0

Created branch 1790_mc_crash

Initial changeset:5de97ebdba276f3b8649b2d500fa384ccc74ab78

Review, please.

Changed 10 years ago by a.panov

panels.ini

Changed 10 years ago by a.panov

output from gdb bt full

comment:5 Changed 10 years ago by iNode

  • Votes for changeset set to iNode

comment:6 Changed 10 years ago by andrew_b

  • Votes for changeset changed from iNode to iNode andrew_b
  • severity changed from on review to approved

comment:7 Changed 10 years ago by slavazanko

  • Status changed from accepted to testing
  • Votes for changeset changed from iNode andrew_b to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:8 Changed 10 years ago by slavazanko

  • Status changed from testing to closed

comment:10 Changed 9 years ago by slyfox

  • Description modified (diff)
Note: See TracTickets for help on using tickets.