Ticket #1603 (closed defect: worksforme)

Opened 10 years ago

Last modified 7 years ago

After copy text from another program (i.e. Kate), inserted text shifted at every string

Reported by: xintrea Owned by:
Priority: major Milestone:
Component: mcedit Version: master
Keywords: shifted strings Cc: ashaduri@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

After copy text from another program (i.e. Kate), inserted text shifted at every string.

Example.

Text in text buffer:

This is line 1
This is line 2
This is line 3
This is line 4
This is line 5

Text in MC after inserting:

This is line 1
   This is line 2
      This is line 3
         This is line 4
           This is line 5

Screenshot: http://i.piccy.info/i4/09/69/91499c678606d2342f9f5810d565.png
http://i.piccy.info/i4/09/69/91499c678606d2342f9f5810d565.png

This effect sometimes arise, objective regularity not view.

Change History

comment:1 Changed 10 years ago by angel_il

select wrong pasted text and press Complete
or
before paste switch off [x] Return does autoindent

comment:2 Changed 10 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid

comment:3 Changed 10 years ago by andrew_b

  • Version 4.7.0-pre1 deleted
  • Milestone 4.7 deleted

comment:4 follow-ups: ↓ 5 ↓ 9 Changed 10 years ago by xintrea

  • Status changed from closed to reopened
  • Resolution invalid deleted

select wrong pasted text and press Complete

"Complete" - it is "Enter" key?
I select wrong pasted text and press Enter. There's nothing doing, text keep as stairs.

or before paste switch off [x] Return does autoindent

You suggest, every time, before paste switch off [x] "Return does autoindent", and after paste switch on [ ] "Return does autoindent"?

Any text editor with function "Return does autoindent" be out this problem. This defect observed only in mcedit.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 10 years ago by angel_il

Replying to xintrea:

select wrong pasted text and press Complete

"Complete" - it is "Enter" key?
I select wrong pasted text and press Enter. There's nothing doing, text keep as stairs.

no, it's Esc-tab (by default)

or before paste switch off [x] Return does autoindent

You suggest, every time, before paste switch off [x] "Return does autoindent", and after paste switch on [ ] "Return does autoindent"?

Any text editor with function "Return does autoindent" be out this problem. This defect observed only in mcedit.

no, it's not mc bug.

comment:6 in reply to: ↑ 5 ; follow-up: ↓ 7 Changed 10 years ago by xintrea

Replying to angel_il:

or before paste switch off [x] Return does autoindent

You suggest, every time, before paste switch off [x] "Return does autoindent", and after paste switch on [ ] "Return does autoindent"?

Any text editor with function "Return does autoindent" be out this problem. This defect observed only in mcedit.

no, it's not mc bug.

Ok, whose this bug?

comment:7 in reply to: ↑ 6 Changed 10 years ago by andrew_b

Replying to xintrea:

Ok, whose this bug?

It's a feature not a bug.

comment:8 Changed 10 years ago by slavazanko

  • Milestone set to Future Releases

comment:9 in reply to: ↑ 4 ; follow-up: ↓ 10 Changed 10 years ago by iNode

Replying to xintrea:

Any text editor with function "Return does autoindent" be out this problem. This defect observed only in mcedit.

vim in terminal emulator, at least (it has special paste mode, as workaround).
So it's not a bug.

comment:10 in reply to: ↑ 9 Changed 10 years ago by xintrea

Any text editor with function "Return does autoindent" be out this problem. This defect observed only in mcedit.

vim in terminal emulator, at least (it has special paste mode, as workaround).
So it's not a bug.

Speed of insert pasted text bespeak about insert procedure work "char by char". Maybe create proprocessing procedure, and delete lead spacers?

comment:11 Changed 10 years ago by ossi

middle-mouse-button pasting with shift pressed always suppressed auto-indent in mcedit (assuming mc can get hold of the modifier keys, so it won't work for remote sessions).
anyway, this problem is kinda invisible as long as #1710 persists.

comment:12 Changed 10 years ago by andrew_b

Seems this bug have been fixed in #1710. Please test.

comment:13 Changed 10 years ago by andrew_b

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Milestone Future Releases deleted

comment:14 Changed 9 years ago by alex_sh

  • Status changed from closed to reopened
  • Resolution fixed deleted

Still not completely fixed as of 4.7.3: the Shift key suppresses indentation in text-mode, but not in X11.
4.6.2.pre1 works fine in both text-mode and X11.
See #2233 for details (it was marked as duplicate of this bug).

comment:15 Changed 9 years ago by alex_sh

Sorry, I meant 4.7.2 instead of 4.7.3 above.

comment:16 Changed 9 years ago by alex_sh

  • Cc ashaduri@… added

comment:17 Changed 8 years ago by andrew_b

  • Version set to master
  • Branch state set to no branch
  • Milestone set to Future Releases

comment:18 Changed 7 years ago by angel_il

  • Status changed from reopened to closed
  • Resolution set to worksforme

see #2661

comment:19 Changed 7 years ago by andrew_b

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.