Ticket #1579 (closed defect: invalid)

Opened 10 years ago

Last modified 9 years ago

Translation defects

Reported by: dmartina Owned by: slavazanko
Priority: major Milestone:
Component: mc-core Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Companion for #1370, to include i18n defective code.

Attachments

help_translate.diff (778 bytes) - added by dmartina 9 years ago.
Prototype: this works!

Change History

comment:1 follow-up: ↓ 3 Changed 10 years ago by dmartina

argument_main_table[] in args.c: Array of strings, marked, but not translated in runtime.

comment:2 Changed 10 years ago by dmartina

...and next arrays in args.c with command line help. Also, I can't find it, but "Usage:" is not translated.

comment:3 in reply to: ↑ 1 ; follow-up: ↓ 5 Changed 10 years ago by slavazanko

Replying to dmartina:

argument_main_table[] in args.c: Array of strings, marked, but not translated in runtime.

It's very strange. We tested it on ru_RU.UTF-8, ru_RU.KOI8-R (glib versions 2,6 2.14, 2.20). In all cases we seen fully-translated help output.

Please, provide info about your envirovement.

comment:4 Changed 10 years ago by dmartina

Let me try carefully:
$> git clone git://midnight-commander.org/git/mc.git
...
$> ./autogen.sh
$> LDFLAGS=-s ./configure --with-samba --with-x --with-included-text --enable-mcserver --enable-charset --enable-extcharset --enable-vfs-mcfs --with-gpm-mouse --with-included-gettext --enable-vfs-undelfs --enable-mcserver
$> make install
$> mc --help
Usage:

mc [OPTION...] [+número] [this_dir] [other_panel_dir]

+número - Línea de comienzo al abrir archivo con editor interno

...
Application Options:

-V, --version Displays the current version
-f, --datadir Print data directory

$> grep -A1 "Print data" po/es.po
msgid "Print data directory"
msgstr "Mostrar directorio de datos"
$> locale
LANG=es_ES.UTF-8
...
$> dpkg --list libglib2*
Desired=Unknown/Install/Remove/Purge/Hold?
| Status=Not/Installed/Config?-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst?-required/X=both-problems (Status,Err: uppercase=bad)

/ Name Version Description

+++-==============-==============-============================================
ii libglib2.0-0 2.16.6-0ubuntu The GLib library of C routines
ii libglib2.0-dat 2.16.6-0ubuntu Common files for GLib library
ii libglib2.0-dev 2.16.6-0ubuntu Development files for the GLib library
un libglib2.0-doc <none> (no description available)

You can see part of the text in English, part in Spanish...

It doesn't make sense if you see it fully translated. Maybe some part of Glib is missing? Which part of the code is actually doing these translations? Where did "Usage:" go?

Changed 9 years ago by dmartina

Prototype: this works!

comment:5 in reply to: ↑ 3 Changed 9 years ago by dmartina

Replying to slavazanko:

Replying to dmartina:

argument_main_table[] in args.c: Array of strings, marked, but not translated in runtime.

It's very strange. We tested it on ru_RU.UTF-8, ru_RU.KOI8-R (glib versions 2,6 2.14, 2.20). In all cases we seen fully-translated help output.

Please, provide info about your envirovement.

$>mc --help_terminal

Without the patch above displays in English and with this patch displays in Spanish. Are you completely sure the russian translation and locales were behaving properly???

comment:6 Changed 9 years ago by dmartina

  • Milestone changed from 4.7 to 4.7.0-pre4

comment:7 Changed 9 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted

comment:8 Changed 9 years ago by slavazanko

Okay, what I do:

1) Adapt my build-script for your envirovement:

configure.mc:

#!/bin/sh

top_srcdir=$(pwd)
BUILD_ROOT=${top_srcdir}/build_root

rm -fR $BUILD_ROOT; mkdir -p $BUILD_ROOT

pushd $BUILD_ROOT

export LANG='es_ES.UTF-8'
export CFLAGS='-DMC_USERCONF_DIR=\".mc2\"'

LDFLAGS=-s ../configure \
    --prefix=${BUILD_ROOT}/INSTALL_ROOT \
    --with-samba \
    --with-x \
    --with-included-text \
    --enable-mcserver \
    --enable-charset \
    --enable-extcharset \
    --enable-vfs-mcfs \
    --with-gpm-mouse \
    --with-included-gettext \
    --enable-vfs-undelfs \
    --enable-mcserver

    make && make install
popd

This script placed in ${src} directory and will called automatically by ./autogen.sh script. Next:

2) export LANG=es_ES.UTF-8
3) cd BUILD_ROOT/INSTALL_ROOT/bin
4) mc --help

Uso:
  mc [OPCIÓN…] [+número] [DIRECTORIO] [SEGUNDO_DIRECTORIO]
 +número - Línea de comienzo al abrir archivo con editor interno

...

.Opciones de ayuda:
  -?, --help                     Mostrar opciones de ayuda
  --help-all                     Muestra todas las opciones de ayuda
  --help-terminal                Opciones de terminal
  --help-color                   Opciones de color

Opciones de la aplicación:
  -V, --version                  Mostrar el número de versión
  -f, --datadir                  Mostrar directorio de datos
..

Si detecta algún fallo puede comunicarlo a mc-devel@gnome.org
incluyendo la descripción obtenida con `mc -V'.

As I asked translate.google.com, this is Spanish text... :)

Some my info:

$ gettext --version
gettext (GNU gettext-runtime) 0.17
...<skip GNU header>
$ pkg-config --modversion glib-2.0
2.16.6

I'm don't reproduce this bug :( Is someone have this bug? (exclude dmartina ;).

And I seen concept-patch. As for me, I don't see difference between current 'master' and 'master' with patch. But if this really helps to you, I'll rework patch.

comment:9 Changed 9 years ago by dmartina

Hmmm, amazing... I have same gettext and glib versions (Ubuntu 8.04).

The "usage" x "uso" is not translated for me and I think this is just glib stuf, so perhaps the glib in my distribution lacks some sort of l10n for Spanish... Never mind and let it be if nobody else has this problem. It's not so serious, anyway.

comment:10 Changed 9 years ago by slavazanko

Okay, I'll rework your concept-patch for fully translate cmd-options help via own wrapper. But I don't have ability to check this patch :) Needs you participate in votes for this ticket...

comment:11 Changed 9 years ago by slavazanko

  • severity changed from no branch to on review

Created branch 1579_options_help_translate

initial changeset:fdd8e65ed15e55b363cbf701c01d686203337d16

Review, please.

comment:12 Changed 9 years ago by dmartina

Some more lines are translated, some remain in English. I would lower priority and change Milestone.

dmartin@acebo:~/git/mc.src$ src/mc --help
Usage:
  mc [OPTION...] [+número] [DIRECTORIO] [SEGUNDO_DIRECTORIO]
 +número - Línea de comienzo al abrir archivo con editor interno


GNU Midnight Commander 4.7.0-pre3-153-gff860ab


Help Options:
  -?, --help                     Show help options
  --help-all                     Show all help options
  --help-terminal                Opciones de terminal
  --help-color                   Opciones de color

Application Options:
  -V, --version                  Mostrar el número de versión
  -f, --datadir                  Mostrar directorio de datos
  -P, --printwd=<file>           Guardar el nombre del directorio en un archivo
  -U, --subshell                 Activar uso de subshell (por defecto)
  -u, --nosubshell               Desactivar el uso de subshell
...

comment:13 Changed 9 years ago by slavazanko

Try to

git pull

and compile again. I added new commit:

comment:14 Changed 9 years ago by dmartina

No changes.

comment:15 follow-up: ↓ 16 Changed 9 years ago by slavazanko

Hm... Looks like untranslated glib-only messages.

Do you have file with Spanish translate for glib? Like:

$ ls -l /usr/share/locale/es/LC_MESSAGES/glib*
-rw-r--r-- 1 root root 38924 Мар 16  2009 /usr/share/locale/es/LC_MESSAGES/glib20.mo

And, next question: is glib on your computer installed from distro-repo, or glib yourself-compiled?

comment:16 in reply to: ↑ 15 Changed 9 years ago by dmartina

Replying to slavazanko:

Hm... Looks like untranslated glib-only messages.

Do you have file with Spanish translate for glib? Like:

$ ls -l /usr/share/locale/es/LC_MESSAGES/glib*
-rw-r--r-- 1 root root 38924 Мар 16  2009 /usr/share/locale/es/LC_MESSAGES/glib20.mo

No. It's not there and I couldn't find anything similar with "locate".

And, next question: is glib on your computer installed from distro-repo, or glib yourself-compiled?

It's Ubuntu's:

dmartin@acebo$ dpkg -l libglib2*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Nombre              Versión            Descripción
+++-===================-===================-======================================================
ii  libglib2.0-0        2.16.6-0ubuntu1.2   The GLib library of C routines
ii  libglib2.0-data     2.16.6-0ubuntu1.2   Common files for GLib library
ii  libglib2.0-dev      2.16.6-0ubuntu1.2   Development files for the GLib library
ii  libglib2.0-doc      2.16.6-0ubuntu1.2   Documentation files for the GLib library

comment:17 Changed 9 years ago by slavazanko

I really don't know what do next. :(

Is you have gnome-terminal or any other glib-based application?
Is you see help as well or partially untranslated?
Is this trouble just in mc?

As you may see in src/args.c, we fully trust to glib in options help output (bedore this branch)/ And we translate own i18n stuff as possible... but some messages glib will compute inside, we don't change this process... :(

comment:18 Changed 9 years ago by slavazanko

  • Milestone changed from 4.7.0-pre4 to 4.7.0

Branch in this ticket don't change any i18n-related strings, therefore I was move ticket to '4.7.0' milestone. If someone have any ideas(patches) - welcome, may be ticket will included into pre4 milestone.

comment:19 Changed 9 years ago by dmartina

I do 100% agree. It seems my (Ubuntu) glib is incomplete. As soon as I get a more reliable reference I will come back to this, but for now it is OK to park it.

comment:20 Changed 9 years ago by slavazanko

  • severity changed from on review to on rework

dmartina, please, say about your current situation with your glib installation. Is trouble solved? Is you have any ideas about?

May be, try to manually compile&install glib and check bug again...

comment:21 Changed 9 years ago by dmartina

I'm now in front of an Ubuntu 9.10 and I tried "gimp --help"; guess what I got? It seems to be that ubuntu doesn't have glib locales, so I wouldn't care anymore. If you get them, fair enough. And cross fngers for next 10.04 release.

comment:22 Changed 9 years ago by slavazanko

:) Okay, is reason for close this ticket here?

comment:23 Changed 9 years ago by slavazanko

  • Status changed from accepted to testing
  • Resolution set to invalid

Branch 1579_options_help_translate was deleted.

comment:24 Changed 9 years ago by slavazanko

  • Status changed from testing to closed

comment:25 Changed 9 years ago by slavazanko

  • Version 4.7.0-pre2 deleted
  • severity changed from on rework to no branch
  • Milestone 4.7.0 deleted
Note: See TracTickets for help on using tickets.