Ticket #1473 (closed defect: invalid)

Opened 10 years ago

Last modified 9 years ago

Switching between "Parsed" and "Raw" crashes MC if non-UTF encoding was selected

Reported by: ache Owned by:
Priority: major Milestone: 4.7
Component: mcview Version: 4.7.0-pre1
Keywords: Cc: ache
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by angel_il) (diff)

To reproduce the bug:

  1. Open in viewer any file (observed on doc, zip, txt, tif)
  2. Select any encodind, except UTF-8 or "default".
  3. Press F8. MC crashes.

When run with LC_ALL=C, MC also crashes on UTF-8 codepage.

Gentoo AMD64

Attachments

mc-F8-crash-log.txt (4.1 KB) - added by ache 10 years ago.
Error messages in the terminal window after a crash, removed whitespace for redability

Change History

comment:1 Changed 10 years ago by angel_il

  • Milestone changed from 4.7.0-pre2 to 4.7.0-pre3

i can't reproduce this

comment:2 follow-up: ↓ 5 Changed 10 years ago by ache

Commit 5518e7ad58d9843b514759b46e7f9913a4f6dee6, deleted ~/.mc, replaced /etc/mc with new files, the bug is still there.

Observed in GNOME terminal 2.24.2-r1, xterm 242, XFCE terminal 0.2.12.

What other info about my system do you need?

Changed 10 years ago by ache

Error messages in the terminal window after a crash, removed whitespace for redability

comment:3 Changed 10 years ago by angel_il

  • Cc ache added
  • Status changed from new to closed
  • Resolution set to invalid

i can't reproduce this. Reopen if pre2 have this bug

comment:4 Changed 10 years ago by angel_il

  • Description modified (diff)

comment:5 in reply to: ↑ 2 Changed 10 years ago by andrew_b

Replying to ache:

What other info about my system do you need?

The following URL will help you to provide the detailed info about crash:
http://www.midnight-commander.org/wiki/doc/tracingCrash

comment:6 Changed 10 years ago by slavazanko

  • Milestone changed from 4.7.0-pre3 to 4.7
Note: See TracTickets for help on using tickets.