Ticket #145 (closed enhancement: fixed)

Opened 11 years ago

Last modified 10 years ago

remove stuff created by autogen.sh

Reported by: Enrico Weigelt <weigelt@…> Owned by: slavazanko
Priority: major Milestone: 4.7
Component: mc-core Version: 4.6.2
Keywords: commited-master Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by metux) (diff)

The files in m4/* seem to be a bit outdated, at least they get
changed by the autogen process.

Attachments

m4-update.001.diff (45.4 KB) - added by anonymous 11 years ago.
Added by email2trac
145_update_m4_files-rev2.patch (175.3 KB) - added by slavazanko 11 years ago.
Remove autogenerated m4/*.m4 files. Some other changes for autocreate *.m4 files

Change History

comment:1 Changed 11 years ago by Enrico Weigelt

  • id set to 145

This message has 0 attachment(s)

comment:2 Changed 11 years ago by slavazanko

  • Description modified (diff)

Is we need to ignore these files (via .gitignore)?

comment:3 Changed 11 years ago by anonymous

this patch updates the m4/*.m4 files to whats changed by autogen.sh

Changed 11 years ago by anonymous

Added by email2trac

comment:4 Changed 11 years ago by metux

  • Keywords review added
  • Type changed from defect to enhancement
  • Description modified (diff)
  • Milestone set to 4.6.2

comment:5 Changed 11 years ago by metux

  • Owner set to metux
  • Status changed from new to accepted

comment:6 Changed 11 years ago by winnie

  • Keywords vote-winnie added

Exact the same changes I see on my box also. .this is very nasty.. therefore +1 from me.

comment:7 Changed 11 years ago by ossi

actually, it is generally considered bad practice to have generated files under version control at all. anything created by the bootstrap process (autogen.sh) should be purged from the tree.

comment:8 Changed 11 years ago by winnie

  • Keywords rework added; review vote-winnie removed
  • Summary changed from update m4/* files to remove stuff created by autogen.sh

well this sounds right. I'm retitling this bug and added the rework keyword. metux do you want to update the patch or should I?

Changed 11 years ago by slavazanko

Remove autogenerated m4/*.m4 files. Some other changes for autocreate *.m4 files

comment:9 Changed 11 years ago by slavazanko

  • Keywords rewiew added; rework removed

see 145_update_m4_files-rev2.patch
Need to review.

comment:10 Changed 11 years ago by slavazanko

  • Milestone changed from 4.6.2 to 4.7

This ticket not a bugreport- this an enhancement.
Therefore need to set milestone 4.7

comment:11 Changed 11 years ago by slavazanko

please, see 145_update_m4_files branch (based on master)

changeset:0e6b076666370e0f9f4c76aa46323c71988b8143

comment:12 Changed 11 years ago by slavazanko

  • Version changed from 4.6.1 to 4.6.2

comment:13 Changed 11 years ago by styx

  • Keywords vote-styx added; rewiew removed

comment:14 Changed 11 years ago by styx

  • Status changed from accepted to assigned
  • Owner changed from metux to slavazanko

comment:15 Changed 11 years ago by styx

  • Keywords review added

comment:16 Changed 11 years ago by slavazanko

  • Status changed from assigned to accepted

comment:17 Changed 11 years ago by slyfox

  • Keywords voty-slyfox approved added; review removed

Looks really good and usable!

comment:18 Changed 11 years ago by slavazanko

  • Keywords commited-master added; vote-styx voty-slyfox approved removed
  • Status changed from accepted to testing
  • Resolution set to fixed

Fixed.

comment:19 Changed 11 years ago by styx

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.